aboutsummaryrefslogtreecommitdiff
path: root/debian/patches/01_use-system-ca-certificates.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/01_use-system-ca-certificates.patch')
-rw-r--r--debian/patches/01_use-system-ca-certificates.patch18
1 files changed, 10 insertions, 8 deletions
diff --git a/debian/patches/01_use-system-ca-certificates.patch b/debian/patches/01_use-system-ca-certificates.patch
index 6f18dcb..258455e 100644
--- a/debian/patches/01_use-system-ca-certificates.patch
+++ b/debian/patches/01_use-system-ca-certificates.patch
@@ -2,22 +2,24 @@ Description: Use the bundle provided by ca-certificates instead of
the embedded one.
Author: Daniele Tricoli <eriol@mornie.org>
Forwarded: not-needed
-Last-Update: 2013-01-19
+Last-Update: 2014-10-08
--- a/requests/certs.py
+++ b/requests/certs.py
-@@ -18,7 +18,7 @@
- def where():
- """Return the preferred certificate bundle."""
- # vendored bundle inside Requests
-- return os.path.join(os.path.dirname(__file__), 'cacert.pem')
-+ return '/etc/ssl/certs/ca-certificates.crt'
+@@ -18,8 +18,8 @@
+ except ImportError:
+ def where():
+ """Return the preferred certificate bundle."""
+- # vendored bundle inside Requests
+- return os.path.join(os.path.dirname(__file__), 'cacert.pem')
++ # On Debian systems use ca-certificates
++ return '/etc/ssl/certs/ca-certificates.crt'
if __name__ == '__main__':
print(where())
--- a/setup.py
+++ b/setup.py
-@@ -41,7 +41,7 @@
+@@ -43,7 +43,7 @@
author_email='me@kennethreitz.com',
url='http://python-requests.org',
packages=packages,