aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorSVN-Git Migration <python-modules-team@lists.alioth.debian.org>2015-10-08 13:41:31 -0700
committerSVN-Git Migration <python-modules-team@lists.alioth.debian.org>2015-10-08 13:41:31 -0700
commitca5cb993a3ce4fbdf50eebd31cb6b71eec9bc391 (patch)
tree0cb1e57a7e04660775dc9426c1e4476082f88d1d /setup.py
parent224200a9815f792f93632d03a38e4f0763ae69ef (diff)
downloadpython-requests-ca5cb993a3ce4fbdf50eebd31cb6b71eec9bc391.tar
python-requests-ca5cb993a3ce4fbdf50eebd31cb6b71eec9bc391.tar.gz
Imported Upstream version 2.2.1
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py14
1 files changed, 10 insertions, 4 deletions
diff --git a/setup.py b/setup.py
index 7de446f..16ba717 100755
--- a/setup.py
+++ b/setup.py
@@ -17,7 +17,7 @@ if sys.argv[-1] == 'publish':
packages = [
'requests',
'requests.packages',
- 'requests.packages.charade',
+ 'requests.packages.chardet',
'requests.packages.urllib3',
'requests.packages.urllib3.packages',
'requests.packages.urllib3.contrib',
@@ -26,12 +26,18 @@ packages = [
requires = []
+with open('README.rst') as f:
+ readme = f.read()
+with open('HISTORY.rst') as f:
+ history = f.read()
+with open('LICENSE') as f:
+ license = f.read()
+
setup(
name='requests',
version=requests.__version__,
description='Python HTTP for Humans.',
- long_description=open('README.rst').read() + '\n\n' +
- open('HISTORY.rst').read(),
+ long_description=readme + '\n\n' + history,
author='Kenneth Reitz',
author_email='me@kennethreitz.com',
url='http://python-requests.org',
@@ -40,7 +46,7 @@ setup(
package_dir={'requests': 'requests'},
include_package_data=True,
install_requires=requires,
- license=open('LICENSE').read(),
+ license=license,
zip_safe=False,
classifiers=(
'Development Status :: 5 - Production/Stable',