aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorSVN-Git Migration <python-modules-team@lists.alioth.debian.org>2015-10-08 13:41:15 -0700
committerSVN-Git Migration <python-modules-team@lists.alioth.debian.org>2015-10-08 13:41:15 -0700
commit4fad8c1375c73a3d4483fe78e4534c7dabc453f5 (patch)
treecd9f3e8c6811892a2cea932b9d1d97b41945b712 /setup.py
downloadpython-requests-4fad8c1375c73a3d4483fe78e4534c7dabc453f5.tar
python-requests-4fad8c1375c73a3d4483fe78e4534c7dabc453f5.tar.gz
Imported Upstream version 0.4.1
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py53
1 files changed, 53 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100755
index 0000000..f0cebcd
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,53 @@
+#!/usr/bin/env python
+# -*- coding: utf-8 -*-
+
+import os
+import sys
+import requests
+
+from distutils.core import setup
+
+
+
+if sys.argv[-1] == "publish":
+ os.system("python setup.py sdist upload")
+ sys.exit()
+
+if sys.argv[-1] == "test":
+ os.system("python test_requests.py")
+ sys.exit()
+
+required = []
+
+if sys.version_info[:2] < (2,6):
+ required.append('simplejson')
+
+setup(
+ name='requests',
+ version=requests.__version__,
+ description='Awesome Python HTTP Library that\'s actually usable.',
+ long_description=open('README.rst').read() + '\n\n' +
+ open('HISTORY.rst').read(),
+ author='Kenneth Reitz',
+ author_email='me@kennethreitz.com',
+ url='http://python-requests.org',
+ packages= [
+ 'requests',
+ 'requests.packages',
+ 'requests.packages.poster'
+ ],
+ install_requires=required,
+ license='ISC',
+ classifiers=(
+ 'Development Status :: 5 - Production/Stable',
+ 'Intended Audience :: Developers',
+ 'Natural Language :: English',
+ 'License :: OSI Approved :: ISC License (ISCL)',
+ 'Programming Language :: Python',
+ 'Programming Language :: Python :: 2.5',
+ 'Programming Language :: Python :: 2.6',
+ 'Programming Language :: Python :: 2.7',
+ # 'Programming Language :: Python :: 3.0',
+ # 'Programming Language :: Python :: 3.1',
+ ),
+)