aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorSVN-Git Migration <python-modules-team@lists.alioth.debian.org>2015-10-08 13:41:34 -0700
committerSVN-Git Migration <python-modules-team@lists.alioth.debian.org>2015-10-08 13:41:34 -0700
commit2c79b40c98c83e352c5479223d581d69b0e7806c (patch)
tree81c85525061fbc4805ff2ec2280f560956c35d64 /setup.py
parentd075cc8a1294c77c994dc5fd220ecb163ed31b93 (diff)
downloadpython-requests-2c79b40c98c83e352c5479223d581d69b0e7806c.tar
python-requests-2c79b40c98c83e352c5479223d581d69b0e7806c.tar.gz
Imported Upstream version 2.4.3
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py10
1 files changed, 8 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index c25b368..813fc87 100755
--- a/setup.py
+++ b/setup.py
@@ -5,6 +5,8 @@ import sys
import requests
+from codecs import open
+
try:
from setuptools import setup
except ImportError:
@@ -27,9 +29,9 @@ packages = [
requires = []
-with open('README.rst') as f:
+with open('README.rst', 'r', 'utf-8') as f:
readme = f.read()
-with open('HISTORY.rst') as f:
+with open('HISTORY.rst', 'r', 'utf-8') as f:
history = f.read()
setup(
@@ -57,6 +59,10 @@ setup(
'Programming Language :: Python :: 2.7',
'Programming Language :: Python :: 3',
'Programming Language :: Python :: 3.3',
+ 'Programming Language :: Python :: 3.4'
),
+ extras_require={
+ 'security': ['pyOpenSSL', 'ndg-httpsclient', 'pyasn1'],
+ },
)