aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorBarry Warsaw <barry@debian.org>2014-05-15 17:09:30 -0400
committerBarry Warsaw <barry@debian.org>2014-05-15 17:09:30 -0400
commit5d260ef8595585de45044acfcc9c47377afba4ac (patch)
treed378f65ded93b43581b3b5c04b824019b432ffa6 /debian/rules
parentfbc54dfcbdef18bb090889eb9c58153e4a2eaf93 (diff)
parent3368c320de1db47b2aad8529278c59bf9745a91c (diff)
downloadpython-requests-5d260ef8595585de45044acfcc9c47377afba4ac.tar
python-requests-5d260ef8595585de45044acfcc9c47377afba4ac.tar.gz
Imported Debian patch 2.2.1-2
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules10
1 files changed, 7 insertions, 3 deletions
diff --git a/debian/rules b/debian/rules
index 6198313..c9d82a1 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,11 +1,15 @@
#!/usr/bin/make -f
-export PYBUILD_DESTDIR_python2=debian/python-requests/
-export PYBUILD_DESTDIR_python3=debian/python3-requests/
-
+export PYBUILD_NAME=requests
%:
dh $@ --with python2,python3 --buildsystem=pybuild
override_dh_installchangelogs:
dh_installchangelogs HISTORY.rst
+
+override_dh_auto_install:
+ dh_auto_install
+ python3 setup.py bdist_wheel \
+ --universal \
+ -d $(CURDIR)/debian/tmp/usr/share/python-wheels