aboutsummaryrefslogtreecommitdiff
path: root/debian/patches
diff options
context:
space:
mode:
authorDaniele Tricoli <eriol@mornie.org>2013-01-19 06:46:15 +0000
committerDaniele Tricoli <eriol@mornie.org>2013-01-19 06:46:15 +0000
commitc01e85089cacc00791f9c238b7d6759c3345b5fd (patch)
tree81414aa37a07ea9cb5eec79c1aebe08ae495c73e /debian/patches
parenta5e8b39bba5d726626ed54dcd16716f9e31e89c3 (diff)
downloadpython-requests-c01e85089cacc00791f9c238b7d6759c3345b5fd.tar
python-requests-c01e85089cacc00791f9c238b7d6759c3345b5fd.tar.gz
debian/patches/01_use-system-ca-certificates.patch
- Use the bundle provided by ca-certificates instead of the embedded one
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/01_use-system-ca-certificates.patch28
-rw-r--r--debian/patches/series1
2 files changed, 29 insertions, 0 deletions
diff --git a/debian/patches/01_use-system-ca-certificates.patch b/debian/patches/01_use-system-ca-certificates.patch
new file mode 100644
index 0000000..5fec645
--- /dev/null
+++ b/debian/patches/01_use-system-ca-certificates.patch
@@ -0,0 +1,28 @@
+Description: Use the bundle provided by ca-certificates instead of
+ the embedded one.
+Author: Daniele Tricoli <eriol@mornie.org>
+Forwarded: not-needed
+Last-Update: 2013-01-19
+
+--- a/requests/certs.py
++++ b/requests/certs.py
+@@ -25,7 +25,7 @@
+ if certifi:
+ return certifi.where()
+
+- return os.path.join(os.path.dirname(__file__), 'cacert.pem')
++ return '/etc/ssl/certs/ca-certificates.crt'
+
+ if __name__ == '__main__':
+ print(where())
+--- a/setup.py
++++ b/setup.py
+@@ -35,7 +35,7 @@
+ author_email='me@kennethreitz.com',
+ url='http://python-requests.org',
+ packages=packages,
+- package_data={'': ['LICENSE', 'NOTICE'], 'requests': ['*.pem']},
++ package_data={'': ['LICENSE', 'NOTICE'],},
+ package_dir={'requests': 'requests'},
+ include_package_data=True,
+ install_requires=requires,
diff --git a/debian/patches/series b/debian/patches/series
index e69de29..29a09e4 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -0,0 +1 @@
+01_use-system-ca-certificates.patch