aboutsummaryrefslogtreecommitdiff
path: root/debian/patches
diff options
context:
space:
mode:
authorDaniele Tricoli <eriol@mornie.org>2012-03-16 17:36:54 +0000
committerDaniele Tricoli <eriol@mornie.org>2012-03-16 17:36:54 +0000
commit9fb6f314a62ca5a5fe018599d3ca56670604a688 (patch)
tree83285a64ab157e4bd612f569ce265c8608af0be2 /debian/patches
parent04560d7f5ca66b98a9f76c57a041b053c4327648 (diff)
downloadpython-requests-9fb6f314a62ca5a5fe018599d3ca56670604a688.tar
python-requests-9fb6f314a62ca5a5fe018599d3ca56670604a688.tar.gz
Refreshed 01_do-not-use-python-certifi.patch
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/01_do-not-use-python-certifi.patch18
1 files changed, 9 insertions, 9 deletions
diff --git a/debian/patches/01_do-not-use-python-certifi.patch b/debian/patches/01_do-not-use-python-certifi.patch
index 9887716..fecaf25 100644
--- a/debian/patches/01_do-not-use-python-certifi.patch
+++ b/debian/patches/01_do-not-use-python-certifi.patch
@@ -2,20 +2,20 @@ Description: To verify SSL certificates for HTTPS requests, use the bundle
provided by ca-certificates instead of python-certifi.
Author: Daniele Tricoli <eriol@mornie.org>
Forwarded: not-needed
-Last-Update: 2012-02-05
+Last-Update: 2012-03-16
--- a/requests/models.py
+++ b/requests/models.py
-@@ -481,9 +481,9 @@
- if not cert_loc:
+@@ -497,9 +497,9 @@
+ if not cert_loc and self.config.get('trust_env'):
cert_loc = os.environ.get('CURL_CA_BUNDLE')
-
+
- # Use the awesome certifi list.
+ # On Debian use the bundle provided by ca-certificates.
if not cert_loc:
- cert_loc = __import__('certifi').where()
+ cert_loc = '/etc/ssl/certs/ca-certificates.crt'
-
+
conn.cert_reqs = 'CERT_REQUIRED'
conn.ca_certs = cert_loc
--- a/setup.py
@@ -23,9 +23,9 @@ Last-Update: 2012-02-05
@@ -21,7 +21,7 @@
os.system('python test_requests.py')
sys.exit()
-
+
-required = ['certifi>=0.0.7',]
+required = []
-
- if is_py3:
- required.append('chardet2')
+ packages = [
+ 'requests',
+ 'requests.packages',