aboutsummaryrefslogtreecommitdiff
path: root/debian/patches
diff options
context:
space:
mode:
authorDaniele Tricoli <eriol@mornie.org>2012-04-23 14:16:10 +0000
committerDaniele Tricoli <eriol@mornie.org>2012-04-23 14:16:10 +0000
commit3afeb12534934d54a410c200bde52da2716cb20e (patch)
tree0d1f516ecc6385cda1a81e5232b5df64b7e14928 /debian/patches
parenta18792cf2b86eee392f80da5690b8747f916653d (diff)
downloadpython-requests-3afeb12534934d54a410c200bde52da2716cb20e.tar
python-requests-3afeb12534934d54a410c200bde52da2716cb20e.tar.gz
Refreshed debian/patches/01_do-not-use-python-certifi.patch
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/01_do-not-use-python-certifi.patch21
1 files changed, 4 insertions, 17 deletions
diff --git a/debian/patches/01_do-not-use-python-certifi.patch b/debian/patches/01_do-not-use-python-certifi.patch
index fecaf25..5873743 100644
--- a/debian/patches/01_do-not-use-python-certifi.patch
+++ b/debian/patches/01_do-not-use-python-certifi.patch
@@ -1,27 +1,14 @@
Description: To verify SSL certificates for HTTPS requests, use the bundle
- provided by ca-certificates instead of python-certifi.
+ provided by ca-certificates instead of python-certifi. Since requests 0.11.2
+ it is not needed to hard-code bundle path because requests will search for it.
Author: Daniele Tricoli <eriol@mornie.org>
Forwarded: not-needed
-Last-Update: 2012-03-16
+Last-Update: 2012-04-23
---- a/requests/models.py
-+++ b/requests/models.py
-@@ -497,9 +497,9 @@
- if not cert_loc and self.config.get('trust_env'):
- cert_loc = os.environ.get('CURL_CA_BUNDLE')
-
-- # Use the awesome certifi list.
-+ # On Debian use the bundle provided by ca-certificates.
- if not cert_loc:
-- cert_loc = __import__('certifi').where()
-+ cert_loc = '/etc/ssl/certs/ca-certificates.crt'
-
- conn.cert_reqs = 'CERT_REQUIRED'
- conn.ca_certs = cert_loc
--- a/setup.py
+++ b/setup.py
@@ -21,7 +21,7 @@
- os.system('python test_requests.py')
+ os.system('python tests/test_requests.py')
sys.exit()
-required = ['certifi>=0.0.7',]