aboutsummaryrefslogtreecommitdiff
path: root/debian/patches/02_use-system-chardet-and-urllib3.patch
diff options
context:
space:
mode:
authorDaniele Tricoli <eriol@mornie.org>2014-01-27 03:13:57 +0000
committerDaniele Tricoli <eriol@mornie.org>2014-01-27 03:13:57 +0000
commit5f8b79676f023e12f10bff3eb10e930ee43e5675 (patch)
treeb6ea2be51e61130109a63d489375500f2d4684fc /debian/patches/02_use-system-chardet-and-urllib3.patch
parent744d4b9b65ccbc34cf1ca422d2b677add693c6c3 (diff)
downloadpython-requests-5f8b79676f023e12f10bff3eb10e930ee43e5675.tar
python-requests-5f8b79676f023e12f10bff3eb10e930ee43e5675.tar.gz
Refreshed 02_use-system-chardet-and-urllib3.patch
Diffstat (limited to 'debian/patches/02_use-system-chardet-and-urllib3.patch')
-rw-r--r--debian/patches/02_use-system-chardet-and-urllib3.patch20
1 files changed, 13 insertions, 7 deletions
diff --git a/debian/patches/02_use-system-chardet-and-urllib3.patch b/debian/patches/02_use-system-chardet-and-urllib3.patch
index 0e2ce92..b9fd2b7 100644
--- a/debian/patches/02_use-system-chardet-and-urllib3.patch
+++ b/debian/patches/02_use-system-chardet-and-urllib3.patch
@@ -2,11 +2,11 @@ Description: Use the system python-chardet and python-urllib3 instead of the
embedded copies.
Author: Daniele Tricoli <eriol@mornie.org>
Forwarded: not-needed
-Last-Update: 2013-10-17
+Last-Update: 2014-01-27
--- a/requests/adapters.py
+++ b/requests/adapters.py
-@@ -11,17 +11,17 @@
+@@ -11,18 +11,18 @@
import socket
from .models import Response
@@ -24,12 +24,14 @@ Last-Update: 2013-10-17
-from .packages.urllib3.exceptions import TimeoutError
-from .packages.urllib3.exceptions import SSLError as _SSLError
-from .packages.urllib3.exceptions import HTTPError as _HTTPError
+-from .packages.urllib3.exceptions import ProxyError as _ProxyError
+from urllib3.exceptions import MaxRetryError
+from urllib3.exceptions import TimeoutError
+from urllib3.exceptions import SSLError as _SSLError
+from urllib3.exceptions import HTTPError as _HTTPError
++from urllib3.exceptions import ProxyError as _ProxyError
from .cookies import extract_cookies_to_jar
- from .exceptions import ConnectionError, Timeout, SSLError
+ from .exceptions import ConnectionError, Timeout, SSLError, ProxyError
from .auth import _basic_auth_str
--- a/requests/compat.py
+++ b/requests/compat.py
@@ -37,7 +39,7 @@ Last-Update: 2013-10-17
pythoncompat
"""
--from .packages import charade as chardet
+-from .packages import chardet
+import chardet
import sys
@@ -53,17 +55,21 @@ Last-Update: 2013-10-17
builtin_str = str
--- a/requests/models.py
+++ b/requests/models.py
-@@ -17,8 +17,8 @@
+@@ -17,10 +17,10 @@
from .auth import HTTPBasicAuth
from .cookies import cookiejar_from_dict, get_cookie_header
+-from .packages.urllib3.fields import RequestField
-from .packages.urllib3.filepost import encode_multipart_formdata
-from .packages.urllib3.util import parse_url
+-from .packages.urllib3.exceptions import DecodeError
++from urllib3.fields import RequestField
+from urllib3.filepost import encode_multipart_formdata
+from urllib3.util import parse_url
++from urllib3.exceptions import DecodeError
from .exceptions import (
HTTPError, RequestException, MissingSchema, InvalidURL,
- ChunkedEncodingError)
+ ChunkedEncodingError, ContentDecodingError)
--- a/setup.py
+++ b/setup.py
@@ -16,12 +16,6 @@
@@ -71,7 +77,7 @@ Last-Update: 2013-10-17
packages = [
'requests',
- 'requests.packages',
-- 'requests.packages.charade',
+- 'requests.packages.chardet',
- 'requests.packages.urllib3',
- 'requests.packages.urllib3.packages',
- 'requests.packages.urllib3.contrib',