aboutsummaryrefslogtreecommitdiff
path: root/debian/control
diff options
context:
space:
mode:
authorDaniele Tricoli <eriol@mornie.org>2012-04-01 10:35:20 +0000
committerDaniele Tricoli <eriol@mornie.org>2012-04-01 10:35:20 +0000
commitd08cbf4b36bd88fbf64fca283b189e4335cba5f5 (patch)
tree0a39e135739b469f61497606c6bbd5fd9242d2c9 /debian/control
parentffdb7144886a4ea37d732f95a61588c674a4e02e (diff)
downloadpython-requests-d08cbf4b36bd88fbf64fca283b189e4335cba5f5.tar
python-requests-d08cbf4b36bd88fbf64fca283b189e4335cba5f5.tar.gz
Updated Description field
Diffstat (limited to 'debian/control')
-rw-r--r--debian/control60
1 files changed, 28 insertions, 32 deletions
diff --git a/debian/control b/debian/control
index 7401f3d..cf877cc 100644
--- a/debian/control
+++ b/debian/control
@@ -27,25 +27,23 @@ Recommends:
python-chardet,
python-gevent
Description: elegant and simple HTTP library for Python, built for human beings
- Requests allow you to send GET, HEAD, PUT, POST, and DELETE
- HTTP requests. You can add headers, form data, multipart files, and
- parameters with simple Python dictionaries, and access the response
- data in the same way. It's powered by urllib2, but it does all the
- hard work and crazy hacks for you.
+ Requests allow you to send HTTP/1.1 requests. You can add headers, form data,
+ multipart files, and parameters with simple Python dictionaries, and access the
+ response data in the same way. It's powered by httplib and urllib3, but it does
+ all the hard work and crazy hacks for you.
.
Features
.
- - Extremely simple GET, HEAD, POST, PUT, DELETE Requests
- - Simple HTTP Header Request Attachment
- - Simple Data/Params Request Attachment
- - Simple Multipart File Uploads
- - CookieJar Support
- - Redirection History
- - Proxy Support
- - Redirection Recursion Urllib Fix
- - Auto Decompression of GZipped Content
- - Unicode URL Support
- - Simple Authentication: Simple URL + HTTP Auth Registry
+ - International Domains and URLs
+ - Keep-Alive & Connection Pooling
+ - Sessions with Cookie Persistence
+ - Browser-style SSL Verification
+ - Basic/Digest Authentication
+ - Elegant Key/Value Cookies
+ - Automatic Decompression
+ - Unicode Response Bodies
+ - Multipart File Uploads
+ - Connection Timeouts
Package: python3-requests
Architecture: all
@@ -57,24 +55,22 @@ Depends:
Recommends:
python3-chardet
Description: elegant and simple HTTP library for Python3, built for human beings
- Requests allow you to send GET, HEAD, PUT, POST, and DELETE
- HTTP requests. You can add headers, form data, multipart files, and
- parameters with simple Python dictionaries, and access the response
- data in the same way. It's powered by urllib2, but it does all the
- hard work and crazy hacks for you.
+ Requests allow you to send HTTP/1.1 requests. You can add headers, form data,
+ multipart files, and parameters with simple Python dictionaries, and access the
+ response data in the same way. It's powered by httplib and urllib3, but it does
+ all the hard work and crazy hacks for you.
.
Features
.
- - Extremely simple GET, HEAD, POST, PUT, DELETE Requests
- - Simple HTTP Header Request Attachment
- - Simple Data/Params Request Attachment
- - Simple Multipart File Uploads
- - CookieJar Support
- - Redirection History
- - Proxy Support
- - Redirection Recursion Urllib Fix
- - Auto Decompression of GZipped Content
- - Unicode URL Support
- - Simple Authentication: Simple URL + HTTP Auth Registry
+ - International Domains and URLs
+ - Keep-Alive & Connection Pooling
+ - Sessions with Cookie Persistence
+ - Browser-style SSL Verification
+ - Basic/Digest Authentication
+ - Elegant Key/Value Cookies
+ - Automatic Decompression
+ - Unicode Response Bodies
+ - Multipart File Uploads
+ - Connection Timeouts
.
This package contains the Python 3 version of the library.