aboutsummaryrefslogtreecommitdiff
path: root/debian/control
diff options
context:
space:
mode:
authorBarry Warsaw <barry@debian.org>2014-05-15 21:08:01 +0000
committerBarry Warsaw <barry@debian.org>2014-05-15 21:08:01 +0000
commit6b1bf3b05c24be6cf5fde5f238a6edce38c53389 (patch)
tree889edb2b70979aac401e46e1a086ea1b6a3b915f /debian/control
parent569b6c3126fe505c126af5f6c2a7a3dc0992c7f7 (diff)
downloadpython-requests-6b1bf3b05c24be6cf5fde5f238a6edce38c53389.tar
python-requests-6b1bf3b05c24be6cf5fde5f238a6edce38c53389.tar.gz
* debian/control
- Add python-requests-wheels binary package. - Build-Depends on python3-wheel, python-setuptools, and python3-setuptools. - wrap-and-sort. * debian/rules: - Simplify by using PYBUILD_NAME. - Build the universal wheels.
Diffstat (limited to 'debian/control')
-rw-r--r--debian/control83
1 files changed, 55 insertions, 28 deletions
diff --git a/debian/control b/debian/control
index c6b855f..c01f6f0 100644
--- a/debian/control
+++ b/debian/control
@@ -3,15 +3,17 @@ Maintainer: Debian Python Modules Team <python-modules-team@lists.alioth.debian.
Uploaders: Daniele Tricoli <eriol@mornie.org>
Section: python
Priority: optional
-Build-Depends:
- debhelper (>= 9),
- dh-python,
- python-all (>= 2.6.6-3),
- python-chardet,
- python-urllib3 (>= 1.7.1),
- python3-all,
- python3-chardet,
- python3-urllib3 (>= 1.7.1)
+Build-Depends: debhelper (>= 9),
+ dh-python,
+ python-all (>= 2.6.6-3),
+ python-chardet,
+ python-setuptools,
+ python-urllib3 (>= 1.7.1),
+ python3-all,
+ python3-chardet,
+ python3-setuptools,
+ python3-urllib3 (>= 1.7.1),
+ python3-wheel
Standards-Version: 3.9.5
X-Python-Version: >= 2.7
X-Python3-Version: >= 3.0
@@ -21,17 +23,16 @@ Vcs-Browser: http://anonscm.debian.org/viewvc/python-modules/packages/requests/t
Package: python-requests
Architecture: all
-Depends:
- ${misc:Depends},
- ${python:Depends},
- ca-certificates,
- python-chardet,
- python-urllib3 (>= 1.7.1),
+Depends: ca-certificates,
+ python-chardet,
+ python-urllib3 (>= 1.7.1),
+ ${misc:Depends},
+ ${python:Depends}
Description: elegant and simple HTTP library for Python, built for human beings
Requests allow you to send HTTP/1.1 requests. You can add headers, form data,
- multipart files, and parameters with simple Python dictionaries, and access the
- response data in the same way. It's powered by httplib and urllib3, but it does
- all the hard work and crazy hacks for you.
+ multipart files, and parameters with simple Python dictionaries, and access
+ the response data in the same way. It's powered by httplib and urllib3, but
+ it does all the hard work and crazy hacks for you.
.
Features
.
@@ -48,17 +49,16 @@ Description: elegant and simple HTTP library for Python, built for human beings
Package: python3-requests
Architecture: all
-Depends:
- ${misc:Depends},
- ${python3:Depends},
- ca-certificates,
- python3-chardet,
- python3-urllib3 (>= 1.5)
-Description: elegant and simple HTTP library for Python3, built for human beings
+Depends: ca-certificates,
+ python3-chardet,
+ python3-urllib3 (>= 1.5),
+ ${misc:Depends},
+ ${python3:Depends}
+Description: elegant and simple HTTP library for Python, built for human beings
Requests allow you to send HTTP/1.1 requests. You can add headers, form data,
- multipart files, and parameters with simple Python dictionaries, and access the
- response data in the same way. It's powered by httplib and urllib3, but it does
- all the hard work and crazy hacks for you.
+ multipart files, and parameters with simple Python dictionaries, and access
+ the response data in the same way. It's powered by httplib and urllib3, but
+ it does all the hard work and crazy hacks for you.
.
Features
.
@@ -74,3 +74,30 @@ Description: elegant and simple HTTP library for Python3, built for human beings
- Connection Timeouts
.
This package contains the Python 3 version of the library.
+
+Package: python-requests-wheels
+Architecture: all
+Depends: ca-certificates,
+ python-urllib3-wheels,
+ ${misc:Depends},
+ ${python3:Depends}
+Description: elegant and simple HTTP library for Python, built for human beings
+ Requests allow you to send HTTP/1.1 requests. You can add headers, form data,
+ multipart files, and parameters with simple Python dictionaries, and access
+ the response data in the same way. It's powered by httplib and urllib3, but
+ it does all the hard work and crazy hacks for you.
+ .
+ Features
+ .
+ - International Domains and URLs
+ - Keep-Alive & Connection Pooling
+ - Sessions with Cookie Persistence
+ - Browser-style SSL Verification
+ - Basic/Digest Authentication
+ - Elegant Key/Value Cookies
+ - Automatic Decompression
+ - Unicode Response Bodies
+ - Multipart File Uploads
+ - Connection Timeouts
+ .
+ This package provides the universal wheels.