aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py24
1 files changed, 24 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..14f3489
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,24 @@
+import os
+from setuptools import setup
+
+setup(
+ name = "prometheus_client",
+ version = "0.0.13",
+ author = "Brian Brazil",
+ author_email = "brian.brazil@robustperception.io",
+ description = ("Python client for the Prometheus monitoring system."),
+ long_description = ("See https://github.com/prometheus/client_python/blob/master/README.md for documentation."),
+ license = "Apache Software License 2.0",
+ keywords = "prometheus monitoring instrumentation client",
+ url = "https://github.com/prometheus/client_python",
+ packages=['prometheus_client', 'prometheus_client.bridge'],
+ test_suite="tests",
+ classifiers=[
+ "Development Status :: 4 - Beta",
+ "Intended Audience :: Developers",
+ "Intended Audience :: Information Technology",
+ "Intended Audience :: System Administrators",
+ "Topic :: System :: Monitoring",
+ "License :: OSI Approved :: Apache Software License",
+ ],
+)