aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py53
1 files changed, 32 insertions, 21 deletions
diff --git a/setup.py b/setup.py
index 7d6706e..c0f1e57 100644
--- a/setup.py
+++ b/setup.py
@@ -40,9 +40,10 @@ import sys
try:
from setuptools import setup
kw = {
- 'install_requires': ['pycrypto >= 2.1, != 2.4',
- 'ecdsa',
- ],
+ 'install_requires': [
+ 'pycrypto >= 2.1, != 2.4',
+ 'ecdsa',
+ ],
}
except ImportError:
from distutils.core import setup
@@ -53,21 +54,31 @@ if sys.platform == 'darwin':
setup_helper.install_custom_make_tarball()
-setup(name = "paramiko",
- version = "1.12.2",
- description = "SSH2 protocol library",
- author = "Jeff Forcier",
- author_email = "jeff@bitprophet.org",
- url = "https://github.com/paramiko/paramiko/",
- packages = [ 'paramiko' ],
- license = 'LGPL',
- platforms = 'Posix; MacOS X; Windows',
- classifiers = [ 'Development Status :: 5 - Production/Stable',
- 'Intended Audience :: Developers',
- 'License :: OSI Approved :: GNU Library or Lesser General Public License (LGPL)',
- 'Operating System :: OS Independent',
- 'Topic :: Internet',
- 'Topic :: Security :: Cryptography' ],
- long_description = longdesc,
- **kw
- )
+setup(
+ name = "paramiko",
+ version = "1.14.0",
+ description = "SSH2 protocol library",
+ long_description = longdesc,
+ author = "Jeff Forcier",
+ author_email = "jeff@bitprophet.org",
+ url = "https://github.com/paramiko/paramiko/",
+ packages = [ 'paramiko' ],
+ license = 'LGPL',
+ platforms = 'Posix; MacOS X; Windows',
+ classifiers = [
+ 'Development Status :: 5 - Production/Stable',
+ 'Intended Audience :: Developers',
+ 'License :: OSI Approved :: GNU Library or Lesser General Public License (LGPL)',
+ 'Operating System :: OS Independent',
+ 'Topic :: Internet',
+ 'Topic :: Security :: Cryptography',
+ 'Programming Language :: Python',
+ 'Programming Language :: Python :: 2',
+ 'Programming Language :: Python :: 2.6',
+ 'Programming Language :: Python :: 2.7',
+ 'Programming Language :: Python :: 3',
+ 'Programming Language :: Python :: 3.2',
+ 'Programming Language :: Python :: 3.3',
+ ],
+ **kw
+)