aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJeremy T. Bouse <jbouse@debian.org>2013-05-25 00:04:32 -0400
committerJeremy T. Bouse <jbouse@debian.org>2013-05-25 00:04:32 -0400
commit1a716ed46d1d556d4ba6798608ab498320acd886 (patch)
treedbcb23de26387e312f7ea09085330eca90e15853 /setup.py
parenta88b8c8c0f591a3bfa8d7984343a27815184f495 (diff)
downloadpython-paramiko-1a716ed46d1d556d4ba6798608ab498320acd886.tar
python-paramiko-1a716ed46d1d556d4ba6798608ab498320acd886.tar.gz
Imported Upstream version 1.10.1upstream/1.10.1
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py20
1 files changed, 12 insertions, 8 deletions
diff --git a/setup.py b/setup.py
index 4537a8a..d6caccf 100644
--- a/setup.py
+++ b/setup.py
@@ -14,7 +14,7 @@
#
# You should have received a copy of the GNU Lesser General Public License
# along with Paramiko; if not, write to the Free Software Foundation, Inc.,
-# 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA.
+# 51 Franklin Street, Suite 500, Boston, MA 02110-1335 USA.
longdesc = '''
@@ -25,6 +25,10 @@ are supported. SFTP client and server mode are both supported too.
Required packages:
pyCrypto
+
+To install the `in-development version
+<https://github.com/paramiko/paramiko/tarball/master#egg=paramiko-dev>`_, use
+`pip install paramiko==dev`.
'''
# if someday we want to *require* setuptools, uncomment this:
@@ -36,23 +40,23 @@ import sys
try:
from setuptools import setup
kw = {
- 'install_requires': 'pycrypto >= 2.1',
+ 'install_requires': 'pycrypto >= 2.1, != 2.4',
}
except ImportError:
from distutils.core import setup
kw = {}
if sys.platform == 'darwin':
- import setup_helper
- setup_helper.install_custom_make_tarball()
+ import setup_helper
+ setup_helper.install_custom_make_tarball()
setup(name = "paramiko",
- version = "1.7.7.1",
+ version = "1.10.1",
description = "SSH2 protocol library",
- author = "Robey Pointer",
- author_email = "robeypointer@gmail.com",
- url = "http://www.lag.net/paramiko/",
+ author = "Jeff Forcier",
+ author_email = "jeff@bitprophet.org",
+ url = "https://github.com/paramiko/paramiko/",
packages = [ 'paramiko' ],
license = 'LGPL',
platforms = 'Posix; MacOS X; Windows',