aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorJeremy T. Bouse <jbouse@debian.org>2013-05-25 00:53:46 -0400
committerJeremy T. Bouse <jbouse@debian.org>2013-05-25 00:53:46 -0400
commit359219d8cf254e9d5019a65349808f9e69e85c4e (patch)
tree7d3512a6fb0a9767acb2b2b3b13a6a11810c2c1e /debian
parentc069246d256f836a4228bcdf714301e45570f6c5 (diff)
downloadpython-paramiko-359219d8cf254e9d5019a65349808f9e69e85c4e.tar
python-paramiko-359219d8cf254e9d5019a65349808f9e69e85c4e.tar.gz
debian/*: clean up build files for new version
Prepare package to be able to have both Py2 and Py3 packages when upstream finishes up the worked needed to support both from a single code base.
Diffstat (limited to 'debian')
-rw-r--r--debian/control9
-rw-r--r--debian/python-paramiko.doc-base (renamed from debian/doc-base)0
-rw-r--r--debian/python-paramiko.docs (renamed from debian/docs)0
-rw-r--r--debian/python-paramiko.install1
-rwxr-xr-xdebian/rules26
5 files changed, 31 insertions, 5 deletions
diff --git a/debian/control b/debian/control
index 99a55e6..6e25a38 100644
--- a/debian/control
+++ b/debian/control
@@ -5,8 +5,9 @@ Maintainer: Jeremy T. Bouse <jbouse@debian.org>
Uploaders: Guido Guenther <agx@debian.org>
Build-Depends: debhelper (>> 8),
python-all (>= 2.6.6-3~),
- python-crypto (>= 2.1.0-2)
-Standards-Version: 3.9.3
+ python-crypto (>= 2.1.0-2),
+ python-setuptools
+Standards-Version: 3.9.4
Homepage: https://github.com/paramiko/paramiko/
Vcs-Git: git://git.debian.org/collab-maint/paramiko.git
Vcs-Browser: http://git.debian.org/?p=collab-maint/paramiko.git
@@ -17,8 +18,10 @@ Depends: ${misc:Depends},
${python:Depends},
python-crypto (>= 2.1.0-2)
Provides: ${python:Provides}
-Description: Make ssh v2 connections with Python
+Description: Make ssh v2 connections with Python (Python 2)
This is a library for making SSH2 connections (client or server).
Emphasis is on using SSH2 as an alternative to SSL for making secure
connections between Python scripts. All major ciphers and hash methods
are supported. SFTP client and server mode are both supported too.
+ .
+ This is the Python 2 version of the package.
diff --git a/debian/doc-base b/debian/python-paramiko.doc-base
index e604928..e604928 100644
--- a/debian/doc-base
+++ b/debian/python-paramiko.doc-base
diff --git a/debian/docs b/debian/python-paramiko.docs
index d60fe81..d60fe81 100644
--- a/debian/docs
+++ b/debian/python-paramiko.docs
diff --git a/debian/python-paramiko.install b/debian/python-paramiko.install
new file mode 100644
index 0000000..b2cc136
--- /dev/null
+++ b/debian/python-paramiko.install
@@ -0,0 +1 @@
+usr/lib/python2*
diff --git a/debian/rules b/debian/rules
index 00d62e3..4703c01 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,10 +1,32 @@
#!/usr/bin/make -f
+PYTHON2=$(shell pyversions -vr)
+
%:
dh $@ --with python2
-override_dh_auto_test:
- ./test.py
+ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
+test-python%:
+ python$* setup.py test -vv
+
+override_dh_auto_test: $(PYTHON2:%=test-python%)
+endif
+
+build-python%:
+ python$* setup.py build
+
+override_dh_auto_build: $(PYTHON2:%=build-python%)
+ dh_auto_build
+
+install-python%:
+ python$* setup.py install --root=$(CURDIR)/debian/tmp --install-layout=deb
+
+override_dh_auto_install: $(PYTHON2:%=install-python%)
+ dh_auto_install
+
+override_dh_installdocs:
+ epydoc --no-private -o docs/ paramiko
+ dh_installdocs
# Commands not to run
override_dh_installcatalogs override_dh_installcron: