aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2015-12-22 16:57:45 +0000
committerChristopher Baines <mail@cbaines.net>2015-12-22 16:57:45 +0000
commitac00c3fafd7c2941152aa4aef02c40cf1a7bf600 (patch)
tree6c8190bad90160d3351c94cb91ec3eaf8ae12abc /debian/rules
parent1b12ec682d65648963ef3166531b9a66a70cacc1 (diff)
downloadpython-jsmin-ac00c3fafd7c2941152aa4aef02c40cf1a7bf600.tar
python-jsmin-ac00c3fafd7c2941152aa4aef02c40cf1a7bf600.tar.gz
Add initial Debian package
Here I am importing the existing Debian source package in to this repository.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules31
1 files changed, 31 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..878c806
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,31 @@
+#!/usr/bin/make -f
+
+PYTHONS:=$(shell pyversions -vr)
+PYTHON3S:=$(shell py3versions -vr)
+
+%:
+ dh $@ --buildsystem=python_distutils --with python2,python3
+
+# shameless steal from zigo's openstack-pkg-tools
+override_dh_installchangelogs:
+ if [ -e $(CURDIR)/debian/CHANGELOG ] ; then \
+ dh_installchangelogs $(CURDIR)/debian/CHANGELOG ; \
+ else \
+ dh_installchangelogs ; \
+ fi
+
+override_dh_auto_install:
+ set -e && for pyvers in $(PYTHONS); do \
+ python$$pyvers setup.py install --install-layout=deb \
+ --root $(CURDIR)/debian/python-jsmin; \
+ done
+ set -e && for pyvers in $(PYTHON3S); do \
+ python$$pyvers setup.py install --install-layout=deb \
+ --root $(CURDIR)/debian/python3-jsmin; \
+ done
+
+override_dh_auto_test:
+ set -e ; for pyvers in $(PYTHONS) $(PYTHON3S); do \
+ PYTHONPATH=$(CURDIR) python$$pyvers jsmin/test.py ; \
+ done
+