aboutsummaryrefslogtreecommitdiff
path: root/debian/patches/01_remove_django_builddeps.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/01_remove_django_builddeps.patch')
-rw-r--r--debian/patches/01_remove_django_builddeps.patch30
1 files changed, 0 insertions, 30 deletions
diff --git a/debian/patches/01_remove_django_builddeps.patch b/debian/patches/01_remove_django_builddeps.patch
deleted file mode 100644
index 664c418..0000000
--- a/debian/patches/01_remove_django_builddeps.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-Forwarded-Upstream: Yes.
-Author: David Spreen <netzwurm@debian.org>
-Comment:
- Since setup.py uses tagging/__init__.py to determine the version number, the
- import statements should be moved to the function that actually uses them.
- This removes a build-dependency on django for packaging which eases the
- transition to Django 1.0.
- .
- Ticket exists at http://code.google.com/p/django-tagging/issues/detail?id=110.
-
---- tagging-trunk/tagging/__init__.py 2008-08-21 11:05:41.000000000 -0700
-+++ tagging-trunk.new/tagging/__init__.py 2008-08-21 13:25:47.000000000 -0700
-@@ -1,7 +1,3 @@
--from django.utils.translation import ugettext as _
--
--from tagging.managers import ModelTaggedItemManager, TagDescriptor
--
- VERSION = (0, 3, 'pre')
-
- class AlreadyRegistered(Exception):
-@@ -17,6 +13,9 @@
- """
- Sets the given model class up for working with tags.
- """
-+ from django.utils.translation import ugettext as _
-+ from tagging.managers import ModelTaggedItemManager, TagDescriptor
-+
- if model in registry:
- raise AlreadyRegistered(
- _('The model %s has already been registered.') % model.__name__)