aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorDavid Spreen <netzwurm@debian.org>2008-08-21 20:49:36 +0000
committerDavid Spreen <netzwurm@debian.org>2008-08-21 20:49:36 +0000
commit97815cae6e7c0bd77283e7e4c531384ba1d120c4 (patch)
tree2bb9f452c7441239d9814d7c3a5938204b5fbff8 /debian
parent4c364834e970bb8553e42b96612e9b89762b807a (diff)
downloadpython-django-tagging-97815cae6e7c0bd77283e7e4c531384ba1d120c4.tar
python-django-tagging-97815cae6e7c0bd77283e7e4c531384ba1d120c4.tar.gz
Addint patchdir.
Diffstat (limited to 'debian')
-rw-r--r--debian/patches/01_remove_django_builddeps.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/debian/patches/01_remove_django_builddeps.patch b/debian/patches/01_remove_django_builddeps.patch
new file mode 100644
index 0000000..664c418
--- /dev/null
+++ b/debian/patches/01_remove_django_builddeps.patch
@@ -0,0 +1,30 @@
+Forwarded-Upstream: Yes.
+Author: David Spreen <netzwurm@debian.org>
+Comment:
+ Since setup.py uses tagging/__init__.py to determine the version number, the
+ import statements should be moved to the function that actually uses them.
+ This removes a build-dependency on django for packaging which eases the
+ transition to Django 1.0.
+ .
+ Ticket exists at http://code.google.com/p/django-tagging/issues/detail?id=110.
+
+--- tagging-trunk/tagging/__init__.py 2008-08-21 11:05:41.000000000 -0700
++++ tagging-trunk.new/tagging/__init__.py 2008-08-21 13:25:47.000000000 -0700
+@@ -1,7 +1,3 @@
+-from django.utils.translation import ugettext as _
+-
+-from tagging.managers import ModelTaggedItemManager, TagDescriptor
+-
+ VERSION = (0, 3, 'pre')
+
+ class AlreadyRegistered(Exception):
+@@ -17,6 +13,9 @@
+ """
+ Sets the given model class up for working with tags.
+ """
++ from django.utils.translation import ugettext as _
++ from tagging.managers import ModelTaggedItemManager, TagDescriptor
++
+ if model in registry:
+ raise AlreadyRegistered(
+ _('The model %s has already been registered.') % model.__name__)