aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py27
1 files changed, 27 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..115d811
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,27 @@
+from setuptools import setup, find_packages
+
+setup(
+ name='bleach',
+ version='1.1.5',
+ description='An easy whitelist-based HTML-sanitizing tool.',
+ long_description=open('README.rst').read(),
+ author='James Socol',
+ author_email='james@mozilla.com',
+ url='http://github.com/jsocol/bleach',
+ license='BSD',
+ packages=find_packages(),
+ include_package_data=True,
+ package_data={'': ['README.rst']},
+ zip_safe=False,
+ install_requires=['html5lib>=0.95'],
+ classifiers=[
+ 'Development Status :: 4 - Beta',
+ 'Environment :: Web Environment',
+ 'Environment :: Web Environment :: Mozilla',
+ 'Intended Audience :: Developers',
+ 'License :: OSI Approved :: BSD License',
+ 'Operating System :: OS Independent',
+ 'Programming Language :: Python',
+ 'Topic :: Software Development :: Libraries :: Python Modules',
+ ]
+)