aboutsummaryrefslogtreecommitdiff
path: root/debian/control
diff options
context:
space:
mode:
Diffstat (limited to 'debian/control')
-rw-r--r--debian/control42
1 files changed, 38 insertions, 4 deletions
diff --git a/debian/control b/debian/control
index 9cbd429..d845fde 100644
--- a/debian/control
+++ b/debian/control
@@ -4,17 +4,29 @@ Priority: optional
Maintainer: Per Andersson <avtobiff@gmail.com>
Standards-Version: 3.9.4
Build-Depends:
- debhelper (>= 7.0.50~),
- python-all,
- python-setuptools
+ debhelper (>= 8),
+ dh-python,
+ python-docutils,
+ python3-all,
+ python3-nose,
+ python3-setuptools,
+ python-all (>= 2.6.6-3~),
+ python-nose,
+ python-setuptools,
+ python3-html5lib,
+ python3-six,
+ python-html5lib,
+ python-six
Homepage: http://github.com/jsocol/bleach/
Vcs-Git: git://anonscm.debian.org/collab-maint/python-bleach.git
Vcs-Browser: http://anonscm.debian.org/gitweb/?p=collab-maint/python-bleach.git;a=summary
+X-Python-Version: >= 2.6
+X-Python3-Version: >= 3.2
Package: python-bleach
Architecture: all
Depends: ${misc:Depends}, ${python:Depends}
-Description: whitelist-based HTML-sanitizing library
+Description: whitelist-based HTML-sanitizing library (Python 2)
Bleach is an HTML sanitizing library that escapes or strips markup and
attributes based on a white list. Bleach can also linkify text safely,
applying filters that Django's urlize filter cannot, and optionally setting
@@ -28,3 +40,25 @@ Description: whitelist-based HTML-sanitizing library
Because it relies on html5lib, Bleach is as good as modern browsers at dealing
with weird, quirky HTML fragments. And any of Bleach's methods will fix
unbalanced or mis-nested tags.
+ .
+ This is the Python 2 version of the package.
+
+Package: python3-bleach
+Architecture: all
+Depends: ${misc:Depends}, ${python3:Depends}
+Description: whitelist-based HTML-sanitizing library (Python 3)
+ Bleach is an HTML sanitizing library that escapes or strips markup and
+ attributes based on a white list. Bleach can also linkify text safely,
+ applying filters that Django's urlize filter cannot, and optionally setting
+ rel attributes, even on links already in the text.
+ .
+ Bleach is intended for sanitizing text from untrusted sources. If you find
+ yourself jumping through hoops to allow your site administrators to do lots of
+ things, you're probably outside the use cases. Either trust those users, or
+ don't.
+ .
+ Because it relies on html5lib, Bleach is as good as modern browsers at dealing
+ with weird, quirky HTML fragments. And any of Bleach's methods will fix
+ unbalanced or mis-nested tags.
+ .
+ This is the Python 3 version of the package.