aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules19
1 files changed, 19 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..6b90827
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,19 @@
+#!/usr/bin/make -f
+# -*- makefile -*-
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+%:
+ dh $@
+
+override_dh_auto_build:
+ carto project.mml > style.xml
+
+override_dh_auto_install:
+ mkdir -p debian/openstreetmap-carto/usr/share/openstreetmap-carto/
+ mv style.xml debian/openstreetmap-carto/usr/share/openstreetmap-carto/
+
+override_dh_auto_clean:
+ dh_auto_clean
+ debconf-updatepo