aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules17
1 files changed, 11 insertions, 6 deletions
diff --git a/debian/rules b/debian/rules
index da8249920..0a6571521 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,13 +1,18 @@
#!/usr/bin/make -f
+%:
+ dh $@
+
+# keeps it out if /usr/local
+override_dh_auto_configure:
+ dh_auto_configure -- PREFIX=/usr
-binary: binary-indep
-binary-indep:
- dh $@ --before dh_compress
+# avoid compressing files in the doc wiki
+override_dh_compress:
dh_compress -Xhtml
- dh $@ --after dh_compress
-%:
- dh $@
+# distclean moans about MANIFEST, this is quieter
+override_dh_auto_clean:
+ $(MAKE) realclean
# Not intended for use by anyone except the author.
announcedir: