aboutsummaryrefslogtreecommitdiff
path: root/Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.PL')
-rwxr-xr-xMakefile.PL8
1 files changed, 6 insertions, 2 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 676ba06ef..43af95c59 100755
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -47,8 +47,12 @@ extra_clean:
extra_install:
install -d $(DESTDIR)$(PREFIX)/share/ikiwiki
- find basewiki templates \( -type f -or -type l \) ! -regex '.*\.svn.*' \
- -exec cp --parents -aL {} $(DESTDIR)$(PREFIX)/share/ikiwiki \;
+ for dir in `find -L basewiki templates -type d ! -regex '.*\.svn.*'`; do \
+ install -d $(DESTDIR)$(PREFIX)/share/ikiwiki/$$dir; \
+ for file in `find -L $$dir -maxdepth 1 -type f`; do \
+ install -m 644 $$file $(DESTDIR)$(PREFIX)/share/ikiwiki/$$dir; \
+ done; \
+ done
install -d $(DESTDIR)$(PREFIX)/share/man/man1
install -m 644 ikiwiki.man $(DESTDIR)$(PREFIX)/share/man/man1/ikiwiki.1