summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/bsd-games-fix-number-test.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/bsd-games-fix-number-test.patch')
-rw-r--r--gnu/packages/patches/bsd-games-fix-number-test.patch32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/patches/bsd-games-fix-number-test.patch b/gnu/packages/patches/bsd-games-fix-number-test.patch
new file mode 100644
index 0000000000..26ff84e51f
--- /dev/null
+++ b/gnu/packages/patches/bsd-games-fix-number-test.patch
@@ -0,0 +1,32 @@
+number is a program that translates the decimal numbers like this:
+0.1 --> one tenth_.
+0.2 --> two tenth_S.
+This patch fix the test.
+
+diff -Naur bsd-games-2.17/tests/number.-0.1 bsd-games-patch/tests/number.-0.1
+--- bsd-games-2.17/tests/number.-0.1 1970-01-01 07:00:00.000000000 +0700
++++ bsd-games-patch/tests/number.-0.1 2020-04-17 15:14:27.831098084 +0700
+@@ -1,3 +1,3 @@
+ minus
+ one.
+-tenths.
++tenth.
+diff -Naur bsd-games-2.17/tests/number.-0.2 bsd-games-patch/tests/number.-0.2
+--- bsd-games-2.17/tests/number.-0.2 1970-01-01 07:00:00.000000000 +0700
++++ bsd-games-patch/tests/number.-0.2 2020-04-17 15:20:48.162336279 +0700
+@@ -0,0 +1,3 @@
++minus
++two.
++tenths.
+diff -Naur bsd-games-2.17/tests/number.test bsd-games-patch/tests/number.test
+--- bsd-games-2.17/tests/number.test 1970-01-01 07:00:00.000000000 +0700
++++ bsd-games-patch/tests/number.test 2020-04-17 15:20:22.774654155 +0700
+@@ -36,6 +36,8 @@
+ testno 1
+ number/number -- -0.1 >test.out 2>&1 || failtest
+ compare test.out tests/number.-0.1
++number/number -- -0.2 >test.out 2>&1 || failtest
++compare test.out tests/number.-0.2
+ rm -f test.out
+
+ testno 2