summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/blktrace-use-rmtree.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/blktrace-use-rmtree.patch')
-rw-r--r--gnu/packages/patches/blktrace-use-rmtree.patch32
1 files changed, 0 insertions, 32 deletions
diff --git a/gnu/packages/patches/blktrace-use-rmtree.patch b/gnu/packages/patches/blktrace-use-rmtree.patch
deleted file mode 100644
index bb0a10da72..0000000000
--- a/gnu/packages/patches/blktrace-use-rmtree.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-From 6d1ce4a3a1a561644695a50c00cbd28494728061 Mon Sep 17 00:00:00 2001
-From: Vincent Legoll <vincent.legoll@gmail.com>
-Date: Mon, 16 Mar 2020 11:43:19 +0100
-Subject: [PATCH 02/10] bno_plot.py: Use shutil.rmtree() instead of
- os.system('/bin/rm')
-
----
- btt/bno_plot.py | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/btt/bno_plot.py b/btt/bno_plot.py
-index f05cfdc..36fc524 100644
---- a/btt/bno_plot.py
-+++ b/btt/bno_plot.py
-@@ -40,7 +40,7 @@ To exit the plotter, enter 'quit' or ^D at the 'gnuplot> ' prompt.
-
- from __future__ import absolute_import
- from __future__ import print_function
--import getopt, glob, os, sys, tempfile
-+import getopt, glob, os, sys, tempfile, shutil
-
- verbose = 0
- cmds = """
-@@ -125,4 +125,4 @@ if __name__ == '__main__':
- sys.exit(1)
-
- os.waitpid(pid, 0)
-- os.system('/bin/rm -rf ' + tmpdir)
-+ shutil.rmtree(tmpdir)
---
-2.20.1
-