summaryrefslogtreecommitdiff
path: root/gnu/packages/messaging.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/messaging.scm')
-rw-r--r--gnu/packages/messaging.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 25bd239d8f..331287fc04 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -2198,4 +2198,42 @@ support for high performance Telegram Bot creation.")
(home-page "https://source.puri.sm/Librem5/purple-mm-sms")
(license license:gpl2+)))
+(define-public chatty
+ (package
+ (name "chatty")
+ (version "0.1.10")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://source.puri.sm/Librem5/chatty.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0czvqwjzsb0rvmgrmbh97m1b35rnwl41j7q32z4fcqb7bschibql"))))
+ (build-system meson-build-system)
+ (native-inputs
+ `(("desktop-file-utils" ,desktop-file-utils) ; for update-desktop-database
+ ("gettext" ,gettext-minimal)
+ ("glib:bin" ,glib "bin")
+ ("gtk+:bin" ,gtk+ "bin")
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("feedbackd" ,feedbackd)
+ ("folks" ,folks)
+ ("libgcrypt" ,libgcrypt)
+ ("libgee" ,libgee)
+ ("libhandy" ,libhandy)
+ ("pidgin" ,pidgin)
+ ("purple-mm-sms" ,purple-mm-sms)
+ ("sqlite" ,sqlite)))
+ (propagated-inputs
+ `(("adwaita-icon-theme" ,adwaita-icon-theme)
+ ("evolution-data-server" ,evolution-data-server)))
+ (synopsis "Mobile client for XMPP and SMS messaging")
+ (description "Chatty is a chat program for XMPP and SMS. It works on mobile
+as well as on desktop platforms. It's based on libpurple and ModemManager.")
+ (home-page "https://source.puri.sm/Librem5/chatty")
+ (license license:gpl3+)))
+
;;; messaging.scm ends here