summaryrefslogtreecommitdiff
path: root/gnu/packages/gtk.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gtk.scm')
-rw-r--r--gnu/packages/gtk.scm49
1 files changed, 0 insertions, 49 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index bea4850d15..4d093a0e0a 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -1445,55 +1445,6 @@ In addition to the low level layout rendering routines, Pango includes
and routines to assist in editing internationalized text.")
(license license:lgpl2.1+)))
-(define-public girara
- (package
- (name "girara")
- (version "0.3.4")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://git.pwmt.org/pwmt/girara")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "08rpw9hkaprm4r853xy1d35i2af1pji8c3mzzl01mmwmyr9p0x8k"))))
- (native-inputs `(("pkg-config" ,pkg-config)
- ("check" ,check)
- ("gettext" ,gettext-minimal)
- ("glib:bin" ,glib "bin")
- ("xorg-server" ,xorg-server-for-tests)))
- ;; Listed in 'Requires.private' of 'girara.pc'.
- (propagated-inputs `(("gtk+" ,gtk+)))
- (arguments
- `(#:phases (modify-phases %standard-phases
- (add-before 'check 'start-xserver
- ;; Tests require a running X server.
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((xorg-server (assoc-ref inputs "xorg-server"))
- (display ":1"))
- (setenv "DISPLAY" display)
-
- ;; On busy machines, tests may take longer than
- ;; the default of four seconds.
- (setenv "CK_DEFAULT_TIMEOUT" "20")
-
- ;; Don't fail due to missing '/etc/machine-id'.
- (setenv "DBUS_FATAL_WARNINGS" "0")
- (zero? (system (string-append xorg-server "/bin/Xvfb "
- display " &")))))))))
- (build-system meson-build-system)
- (home-page "https://pwmt.org/projects/girara/")
- (synopsis "Library for minimalistic gtk+3 user interfaces")
- (description "Girara is a library that implements a user interface that
-focuses on simplicity and minimalism. Currently based on GTK+, a
-cross-platform widget toolkit, it provides an interface that focuses on three
-main components: a so-called view widget that represents the actual
-application, an input bar that is used to execute commands of the
-application and the status bar which provides the user with current
-information.")
- (license license:zlib)))
-
(define-public gtk-doc
(package
(name "gtk-doc")