summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm56
1 files changed, 56 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 1efc50e6d1..711f4779c7 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -10471,3 +10471,59 @@ and shovers to get to the goal. Race against the clock to collect coins to
earn extra balls. Also included is Neverputt, which is a 3D miniature golf
game.") ;thanks to Debian for description
(license license:gpl2+))))
+
+(define-public taisei
+ (package
+ (name "taisei")
+ (version "1.3.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/taisei-project/"
+ "taisei/releases/download/v" version
+ "/taisei-v" version ".tar.xz"))
+ (sha256
+ (base32
+ "11f9mlqmzy1lszwcc1nsbar9q1hs4ml6pbm52hqfd4q0f4x3ln46"))))
+ (build-system meson-build-system)
+ (arguments
+ `(;;configure option developer=true enables the diagnostics
+ ;;needed for bug reports. it is 'true' if not "release"
+ ;;#:build-type "release"
+ #:configure-flags
+ (list "-Dr_gles30=true"
+ "-Dshader_transpiler=true"
+ "-Dr_gles20=true")))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("python" ,python)
+ ("python-docutils" ,python-docutils)
+ ("python-pygments" ,python-pygments)))
+ (inputs
+ `(("freetype" ,freetype)
+ ("libpng" ,libpng)
+ ("libwebp" ,libwebp)
+ ("libzip" ,libzip)
+ ("mesa" ,mesa)
+ ("openssl" ,openssl)
+ ("opusfile" ,opusfile)
+ ("sdl2" ,sdl2)
+ ("sdl2-mixer" ,sdl2-mixer)
+ ("shaderc" ,shaderc)
+ ("spirv-cross" ,spirv-cross)
+ ("zlib" ,zlib)))
+ (home-page "https://taisei-project.org/")
+ (synopsis "Fangame and libre clone of Touhou Project")
+ (description
+ "Taisei is a shoot-em-up game: The player controls a character (one of
+three: \"Good\", \"Bad\", and \"Dead\"), dodges the missiles (lots of it cover
+the screen, but the character's \"hitbox\" is very small), and shoot at the
+adversaries that keep appear on the screen. At the same time, player lose one
+\"life\" when being hit. If player are out of \"lives\", it’s a Game Over.
+Player have a few \"Continues\" to keep playing (but without scores).")
+ (license (list license:expat ;game
+ license:cc-by4.0 ;resources/00-taisei.pkgdir/bgm/
+ ;atlas/portraits/
+ ;;miscellaneous
+ license:cc0
+ license:public-domain))))