summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/cran.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 70cb7cc700..8b27279f2b 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -21162,3 +21162,25 @@ evaluated interactively.")
Bayes factors, posterior model probabilities, and normalizing constants in
general, via different versions of bridge sampling.")
(license license:gpl2+)))
+
+(define-public r-restrserve
+ (package
+ (name "r-restrserve")
+ (version "0.2.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "RestRserve" version))
+ (sha256
+ (base32 "1b8wbar98qhhl46s4i7qks5nm2wy5bvfi9029gpd4gmqsq4bmbm7"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-rserve" ,r-rserve)))
+ (home-page "https://restrserve.org")
+ (synopsis "R web API framework")
+ (description
+ "RestRserve is an R web API framework for building high-performance AND
+robust microservices and app backends. With Rserve backend on UNIX-like systems
+it is parallel by design. It will handle incoming requests in parallel - each
+request in a separate fork.")
+ (license license:gpl2+)))