summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/zig.scm59
1 files changed, 59 insertions, 0 deletions
diff --git a/gnu/packages/zig.scm b/gnu/packages/zig.scm
new file mode 100644
index 0000000000..ccd8327aed
--- /dev/null
+++ b/gnu/packages/zig.scm
@@ -0,0 +1,59 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2020 Simon A. Nielsen Knights <tauoverpiu@yandex.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages zig)
+ #:use-module (guix packages)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix download)
+ #:use-module (guix build-system cmake)
+ #:use-module (gnu packages xml)
+ #:use-module (gnu packages compression)
+ #:use-module (gnu packages llvm))
+
+(define-public zig-0.5.0
+ (package
+ (version "0.5.0")
+ (name "zig")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://ziglang.org/download/"
+ version "/zig-"
+ version ".tar.xz"))
+ (sha256
+ (base32
+ "0ccahg6bfm9m1mzr5gqs2jd5a3idj1q8akwbz6fcnaqm1yb1dbjm"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'build 'fix-build
+ (lambda _ (setenv "HOME" "/tmp") #t)))))
+ (inputs
+ `(("llvm" ,llvm-9)
+ ("clang" ,clang-9)
+ ("libxml2" ,libxml2)
+ ("zlib" ,zlib)))
+ (description
+ "Programming languaged designed for robustness, optimality, and clarity")
+ (synopsis
+ "Programming languaged designed for robustness, optimality, and clarity")
+ (home-page "https://ziglang.org")
+ (license license:expat)))
+
+(define-public zig zig-0.5.0)