summaryrefslogtreecommitdiff
path: root/nix/local.mk
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice via Guix-patches via <guix-patches@gnu.org>2020-05-14 15:48:46 +0200
committerGuix Patches Tester <>2020-05-14 14:51:17 +0100
commit0b66caa4bb65849cebb30247577c92d156c92e21 (patch)
treef5131d3e3e7b0c86d94eaa41b5cbcfcc56554558 /nix/local.mk
parent85eed078ff7b8a7a9f648f7cd72dfac8851609bc (diff)
downloadpatches-series-3956.tar
patches-series-3956.tar.gz
etc: Add a systemd unit to bind-mount @storedir@ read-only.series-3956
* etc/gnu-store.mount.in: New file. * nix/local.mk (nodist_systemdservice_DATA): Add it. (etc/%.mount): New rule. * etc/guix-install.sh (sys_enable_guix_daemon): Install it. * doc/guix.texi (Binary Installation): Document it.
Diffstat (limited to 'nix/local.mk')
-rw-r--r--nix/local.mk12
1 files changed, 11 insertions, 1 deletions
diff --git a/nix/local.mk b/nix/local.mk
index a64bdd2137..435fdd389a 100644
--- a/nix/local.mk
+++ b/nix/local.mk
@@ -155,7 +155,17 @@ noinst_HEADERS = \
# The '.service' files for systemd.
systemdservicedir = $(libdir)/systemd/system
-nodist_systemdservice_DATA = etc/guix-daemon.service etc/guix-publish.service
+nodist_systemdservice_DATA = \
+ etc/gnu-store.mount \
+ etc/guix-daemon.service \
+ etc/guix-publish.service
+
+etc/%.mount: etc/%.mount.in \
+ $(top_builddir)/config.status
+ $(AM_V_GEN)$(MKDIR_P) "`dirname $@`"; \
+ $(SED) -e 's|@''storedir''@|$(storedir)|' < \
+ "$<" > "$@.tmp"; \
+ mv "$@.tmp" "$@"
etc/guix-%.service: etc/guix-%.service.in \
$(top_builddir)/config.status