summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/bsd-games-bad-ntohl-cast.patch
diff options
context:
space:
mode:
authorVitaliy Shatrov <D0dyBo0D0dyBo0@protonmail.com>2020-04-24 20:18:31 +0700
committerGuix Patches Tester <>2020-04-24 15:09:16 +0100
commit55aceef934b8e8165e1653e9fbf80604fda72b65 (patch)
tree5ad3587ba26025a36662fe8ff572d0142cda00f4 /gnu/packages/patches/bsd-games-bad-ntohl-cast.patch
parent4ac3461a80338c9596b938b25d6f517af43330f0 (diff)
downloadpatches-series-3656.tar
patches-series-3656.tar.gz
gnu: Add bsd-games.series-3656
* gnu/packages/games.scm (bsd-games): a new variable. New patches, taken from Arch and Debian: * gnu/packages/patches/bsd-games-2.17-64bit.patch * gnu/packages/patches/bsd-games-bad-ntohl-cast.patch * gnu/packages/patches/bsd-games-fix-number-test.patch * gnu/packages/patches/bsd-games-gamescreen.h.patch * gnu/packages/patches/bsd-games-getline.patch * gnu/packages/patches/bsd-games-null-check.patch * gnu/packages/patches/bsd-games-number.c.patch * gnu/packages/patches/bsd-games-stdio.h.patch New patches: * gnu/packages/patches/bsd-games-add-configure-config.patch * gnu/packages/patches/bsd-games-add-word-list.patch * gnu/packages/patches/bsd-games-add-wrapper.patch * gnu/packages/patches/bsd-games-dont-install-empty-files.patch * gnu/packages/patches/bsd-games-use-anthology-style-naming.patch
Diffstat (limited to 'gnu/packages/patches/bsd-games-bad-ntohl-cast.patch')
-rw-r--r--gnu/packages/patches/bsd-games-bad-ntohl-cast.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/patches/bsd-games-bad-ntohl-cast.patch b/gnu/packages/patches/bsd-games-bad-ntohl-cast.patch
new file mode 100644
index 0000000000..f783813e95
--- /dev/null
+++ b/gnu/packages/patches/bsd-games-bad-ntohl-cast.patch
@@ -0,0 +1,22 @@
+diff --git a/hunt/hunt/playit.c b/hunt/hunt/playit.c
+index 9acf86e..881a4e7 100644
+--- a/hunt/hunt/playit.c
++++ b/hunt/hunt/playit.c
+@@ -114,7 +114,7 @@ playit()
+ bad_con();
+ /* NOTREACHED */
+ }
+- if (ntohl(version) != (unsigned long)HUNT_VERSION) {
++ if (ntohl(version) != (uint32_t)HUNT_VERSION) {
+ bad_ver();
+ /* NOTREACHED */
+ }
+@@ -649,7 +649,7 @@ do_message()
+ bad_con();
+ /* NOTREACHED */
+ }
+- if (ntohl(version) != (unsigned long)HUNT_VERSION) {
++ if (ntohl(version) != (uint32_t)HUNT_VERSION) {
+ bad_ver();
+ /* NOTREACHED */
+ }