summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorB. Wilson <elaexuotee@wilsonb.com>2020-05-11 20:10:48 +0900
committerGuix Patches Tester <>2020-05-11 12:28:17 +0100
commitadbd26505f1932c0bb55d6e2474575c680f7d84b (patch)
tree6cdf1eecaae9cefb6f9ccec11aa757d6b41ee997
parentcef0e08c235d1eb9943571648ef57a59041bb292 (diff)
downloadpatches-series-3914.tar
patches-series-3914.tar.gz
gnu: Add metamath.series-3914
* gnu/packages/maths.scm (metamath): New variable.
-rw-r--r--gnu/packages/maths.scm74
1 files changed, 74 insertions, 0 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 9df547f1b4..2afca616ab 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -38,6 +38,7 @@
;;; Copyright © 2020 R Veera Kumar <vkor@vkten.in>
;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
;;; Copyright © 2020 Nicolò Balzarotti <nicolo@nixo.xyz>
+;;; Copyright © 2020 B. Wilson <elaexuotee@wilsonb.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -5608,3 +5609,76 @@ and conversions, physical constants, symbolic calculations (including
integrals and equations), arbitrary precision, uncertainity propagation,
interval arithmetic, plotting.")
(license license:gpl2+)))
+
+(define-public metamath
+ (package
+ (name "metamath")
+ (version "0.182")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/metamath/metamath-exe.git")
+ (commit "5df616efe4119ff88daf77e7041d45b6fa39c578")))
+ (sha256
+ (base32 "0amjdgy42c7jypf6sz98iczlxcyl9bqx67ws1q8w2zdqk2izsyjp"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("book"
+ ,(origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/metamath/"
+ "metamath-book/archive/second_edition.tar.gz"))
+ (sha256
+ (base32
+ "1kbgajik9dn870db1zslqyvhn2j8g7shb8d6dm6njwqfkygiliir"))))))
+ (native-inputs `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("texlive" ,(texlive-union
+ (list texlive-amsfonts
+ texlive-bibtex
+ texlive-breqn
+ texlive-makecell
+ texlive-microtype
+ texlive-tabu
+ texlive-latex-anysize
+ texlive-latex-hyperref
+ texlive-latex-needspace
+ texlive-latex-tools)))))
+ (outputs '("out" "doc"))
+ (arguments
+ `(#:phases
+ (let ((book-builddir "metamath-book-second_edition"))
+ (modify-phases %standard-phases
+ (add-after 'unpack 'unpack-doc
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((book-tar (assoc-ref inputs "book")))
+ (invoke "tar" "xzf" book-tar))))
+ (add-after 'build 'build-doc
+ (lambda _
+ (with-directory-excursion book-builddir
+ (invoke "touch" "metamath.ind")
+ (invoke "pdflatex" "metamath")
+ (invoke "pdflatex" "metamath")
+ (invoke "bibtex" "metamath")
+ (invoke "makeindex" "metamath")
+ (invoke "pdflatex" "metamath")
+ (invoke "pdflatex" "metamath"))))
+ (add-after 'build-doc 'install-doc
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((docdir (assoc-ref outputs "doc")))
+ (install-file
+ (string-append book-builddir "/metamath.pdf")
+ (string-append docdir "/share/doc/metamath"))
+ #t)))))))
+ (home-page "http://us.metamath.org/")
+ (synopsis "Proof verifier based on a minimalistic formalism")
+ (description "Metamath is a tiny formal language and that can express
+theorems in abstract mathematics, with an accompyaning @code{metamath}
+executable that verifies databases of these proofs. There is a public
+database, @url{https://github.com/metamath/set.mm, set.mm}, implementing
+first-order logic and Zermelo-Frenkel set theory with Choice, along with a
+large swath of associated, high-level theorems, e.g. the Fundamental Theorem of
+Arithmetic, the Cauchy-Schwarz Inequality, Striling's Formula, etc. See the
+Metamath book")
+ (license license:gpl2+)))