summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThovthe <thovthe@protonmail.com>2020-05-02 22:48:30 +0000
committerGuix Patches Tester <>2020-05-03 08:41:14 +0100
commit46f7af46f64feb7d94a2bab71ddaeafbad0842ea (patch)
tree0001acfd214c09aad3fe74db1f4251e52cfa6208
parent1463079a2dc855df2274a2429dd48adc4d31ffdb (diff)
downloadpatches-series-3826.tar
patches-series-3826.tar.gz
2020-05-02 Thovthe thovthe@protonmail.comseries-3826
* added new package definition for QDirStat at gnu/packages/qdirstat.scm
-rw-r--r--gnu/packages/qdirstat.scm46
1 files changed, 46 insertions, 0 deletions
diff --git a/gnu/packages/qdirstat.scm b/gnu/packages/qdirstat.scm
new file mode 100644
index 0000000000..91581a206e
--- /dev/null
+++ b/gnu/packages/qdirstat.scm
@@ -0,0 +1,46 @@
+(define-module (qdirstat)
+ #:use-module (gnu packages qt)
+ #:use-module (gnu packages compression)
+ #:use-module (guix build-system gnu)
+ #:use-module (guix git-download)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix packages))
+
+
+(define-public qdirstat
+ (package
+ (name "qdirstat")
+ (version "1.6.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/shundhammer/qdirstat.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0q77a347qv1aka6sni6l03zh5jzyy9s74aygg554r73g01kxczpb"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'configure
+ (lambda* (#:key outputs #:allow-other-keys)
+ (invoke "qmake"
+ (string-append "PREFIX="
+ (assoc-ref outputs "out"))
+ (string-append "INSTALL_PREFIX="
+ (assoc-ref outputs "out"))))))))
+
+ (inputs
+ `(("qtbase" ,qtbase)))
+ (native-inputs
+ `(("zlib" ,zlib)
+ ("qttools" ,qttools)))
+ (home-page "https://github.com/shundhammer/qdirstat")
+ (synopsis "Graphical disk space inspection utility")
+ (description
+ "QDirStat is a graphical application to show where your disk space has
+gone and to help you to clean it up. Shaded boxes represent files and files
+are grouped by directory structure." )
+ (license license:gpl2+)))