summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2020-05-02 19:11:18 +0200
committerGuix Patches Tester <>2020-05-02 18:13:16 +0100
commit312090119ea664107642339202fb35e2f92e0e2c (patch)
tree79157a0bfb4f4021d8bf89fa6f972ec94381d404
parent9a764e9d563bf210b9f2ade780f87b27348bc4da (diff)
downloadpatches-series-3815.tar
patches-series-3815.tar.gz
gnu: Add heads-diesel.series-3815
* gnu/packages/heads.scm (heads-diesel): New variable.
-rw-r--r--gnu/packages/heads.scm17
1 files changed, 17 insertions, 0 deletions
diff --git a/gnu/packages/heads.scm b/gnu/packages/heads.scm
index e42dc66c6c..10932967b5 100644
--- a/gnu/packages/heads.scm
+++ b/gnu/packages/heads.scm
@@ -667,3 +667,20 @@ servers.")
`(#:make-flags
'("BOARD=kgpe-d16")
,@(package-arguments heads-coreboot)))))
+
+(define-public heads-diesel
+ (package
+ (inherit heads-coreboot)
+ (name "heads-diesel")
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'remove-extra-fv
+ (lambda _
+ (substitute* "edk2/MdeModulePkg/Core/Dxe/DxeMain/DxeMain.c"
+ (("ProduceFVBProtocolOnBuffer.*")
+ "\n"))
+ #t)))
+ #:make-flags
+ '("BOARD=diesel")
+ ,@(package-arguments heads-coreboot)))))