summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Lemmer Webber <cwebber@dustycloud.org>2020-04-28 15:18:20 -0400
committerGuix Patches Tester <>2020-04-28 21:23:14 +0100
commit201c6df1ac786a4feadc150bf649acb8345fdefd (patch)
tree7b720accb20fdd776e92b064372efdc5ba7e22f0
parent0b25812872904d61024791778dae36636c52ded6 (diff)
downloadpatches-series-3730.tar
patches-series-3730.tar.gz
gnu: Add python-jarco-classes.series-3730
* gnu/packages/python-xyz.scm (python-jarco-classes): New variable.
-rw-r--r--gnu/packages/python-xyz.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 31cafd47d1..3998475c3d 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -19588,3 +19588,41 @@ workspace...")
dependencies. It implements the @uref{http://opensoundcontrol.org/spec-1_0,
Open Sound Control 1.0} specification.")
(license license:unlicense)))
+
+(define-public python-jaraco-classes
+ (package
+ (name "python-jaraco.classes")
+ (version "3.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "jaraco.classes" version))
+ (sha256
+ (base32
+ "1avsxzm5mwylmy2zbxq3xvn48z5djb0qy3hwv4ryncprivzri1n3"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ ;; Not importing the googleapis package for now
+ (add-after 'unpack 'ignore-googleapis
+ (lambda _
+ (substitute* "setup.py"
+ (("'pytest-black-multipy',") ""))
+ #t)))))
+ (propagated-inputs
+ `(("python-more-itertools" ,python-more-itertools)))
+ (native-inputs
+ `(("python-pytest" ,python-pytest)
+ ("python-pytest-checkdocs" ,python-pytest-checkdocs)
+ ("python-pytest-cov" ,python-pytest-cov)
+ ("python-pytest-flake8" ,python-pytest-flake8)
+ ("python-setuptools-scm" ,python-setuptools-scm)))
+ (home-page
+ "https://github.com/jaraco/jaraco.classes")
+ (synopsis
+ "Utility functions for Python class constructs")
+ (description
+ "This package provides utility functions for Python class constructs.")
+ (license license:expat)))
+