summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaghav Gururajan <raghavgururajan@disroot.org>2020-04-28 05:02:06 -0400
committerGuix Patches Tester <>2020-04-28 10:25:15 +0100
commita02ae0db7d5c581b992a621a549bc1fc2834abb2 (patch)
treec5b1f25308bdfa9e38f36cddc581af9d142c5749
parent62d45e463c3b1ecad90004c47356cba342dd23d8 (diff)
downloadpatches-series-3709.tar
patches-series-3709.tar.gz
gnu: spacefm: Fix privilege and disk management.series-3709
* gnu/packages/lxde.scm (spacefm): Fix privilege and disk management. Patched references to su, ktsuss and udevil; to load them correctly.
-rw-r--r--gnu/packages/lxde.scm34
1 files changed, 27 insertions, 7 deletions
diff --git a/gnu/packages/lxde.scm b/gnu/packages/lxde.scm
index 9de96a21cb..d152f6f79d 100644
--- a/gnu/packages/lxde.scm
+++ b/gnu/packages/lxde.scm
@@ -27,6 +27,7 @@
(define-module (gnu packages lxde)
#:use-module (gnu packages)
+ #:use-module (gnu packages admin)
#:use-module (gnu packages autotools)
#:use-module (gnu packages bash)
#:use-module (gnu packages disk)
@@ -279,7 +280,6 @@ with freedesktop.org standard.")
`(("bash" ,bash)
("cairo" ,cairo)
("curlftpfs" ,curlftpfs)
- ("dbus" ,dbus)
("eudev" ,eudev)
("fakeroot" ,fakeroot)
("ffmpegthumbnailer" ,ffmpegthumbnailer)
@@ -288,6 +288,7 @@ with freedesktop.org standard.")
("gtk+" ,gtk+)
("ifuse" ,ifuse)
("jmtpfs" ,jmtpfs)
+ ("ktsuss" ,ktsuss)
("libx11" ,libx11)
("lsof" ,lsof)
("pango" ,pango)
@@ -297,12 +298,31 @@ with freedesktop.org standard.")
("util-linux" ,util-linux)
("wget" ,wget)))
(arguments
- `(#:configure-flags (list (string-append "--with-bash-path="
- (assoc-ref %build-inputs "bash")
- "/bin/bash")
- (string-append "--sysconfdir="
- (assoc-ref %outputs "out")
- "/etc"))))
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-source-files
+ (lambda* (#:key inputs #:allow-other-keys)
+ ;; Patch config file to load programs correctly.
+ (substitute* "etc/spacefm.conf"
+ (("#terminal_su=/bin/su")
+ "terminal_su=/run/setuid-programs/su")
+ (("#graphical_su=/usr/bin/gksu")
+ (string-append "graphical_su="
+ (string-append (assoc-ref inputs "ktsuss")
+ "/bin/ktsuss"))))
+ ;; SpaceFM expects udevil to have uid set to root.
+ ;; User has to manually add udevil to setuid-programs.
+ (substitute* "src/settings.c"
+ (("/usr/bin/udevil")
+ "/run/setuid-programs/udevil"))
+ #t)))
+ #:configure-flags (list
+ (string-append "--with-bash-path="
+ (assoc-ref %build-inputs "bash")
+ "/bin/bash")
+ (string-append "--sysconfdir="
+ (assoc-ref %outputs "out")
+ "/etc"))))
(home-page "https://ignorantguru.github.io/spacefm/")
(synopsis "Multi-panel tabbed file manager")
(description "SpaceFM is a graphical, multi-panel, tabbed file manager