summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaghav Gururajan <raghavgururajan@disroot.org>2020-04-21 20:10:50 -0400
committerGuix Patches Tester <>2020-04-22 01:18:07 +0100
commit3465dca86f7ea8ba7f20d3848f69b50869eb0ecb (patch)
tree03e074ca02bce6bde83948da54a649f83e664406
parent6e8f58fe31884e48ff771d0093fa6bbc77c40ed7 (diff)
downloadpatches-series-3622.tar
patches-series-3622.tar.gz
gnu: spacefm: Add and configure missing dependencies.series-3622
* gnu/packages/lxde.scm (spacefm): Add and configure missing dependencies.
-rw-r--r--gnu/packages/lxde.scm81
1 files changed, 61 insertions, 20 deletions
diff --git a/gnu/packages/lxde.scm b/gnu/packages/lxde.scm
index f5dc027e03..e6fc5b14c8 100644
--- a/gnu/packages/lxde.scm
+++ b/gnu/packages/lxde.scm
@@ -27,15 +27,19 @@
(define-module (gnu packages lxde)
#:use-module (gnu packages)
+ #:use-module (gnu packages admin)
#:use-module (gnu packages autotools)
#:use-module (gnu packages bash)
+ #:use-module (gnu packages disk)
#:use-module (gnu packages docbook)
+ #:use-module (gnu packages file-systems)
#:use-module (gnu packages freedesktop)
#:use-module (gnu packages gettext)
#:use-module (gnu packages glib)
#:use-module (gnu packages gnome)
#:use-module (gnu packages gtk)
#:use-module (gnu packages image-viewers)
+ #:use-module (gnu packages libusb)
#:use-module (gnu packages linux)
#:use-module (gnu packages lsof)
#:use-module (gnu packages openbox)
@@ -43,9 +47,12 @@
#:use-module (gnu packages polkit)
#:use-module (gnu packages text-editors)
#:use-module (gnu packages video)
+ #:use-module (gnu packages wget)
#:use-module (gnu packages wm)
#:use-module (gnu packages xml)
+ #:use-module (gnu packages xdisorg)
#:use-module (gnu packages xorg)
+ #:use-module (guix build-system glib-or-gtk)
#:use-module (guix build-system gnu)
#:use-module (guix build-system trivial)
#:use-module (guix download)
@@ -249,8 +256,8 @@ with freedesktop.org standard.")
"https://github.com/IgnorantGuru/spacefm/archive/"
version ".tar.gz"))
(sha256
- (base32
- "1jg7xfyr7kihjnalxp8wxyb9qjk8hqf5l36rp3s0lvkpmpyakppy"))
+ (base32
+ "1jg7xfyr7kihjnalxp8wxyb9qjk8hqf5l36rp3s0lvkpmpyakppy"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -262,25 +269,59 @@ with freedesktop.org standard.")
"#include <sys/sysmacros.h>\n")))
#t))
(file-name (string-append name "-" version ".tar.gz"))))
- (build-system gnu-build-system)
- (native-inputs `(("pkg-config" ,pkg-config)
- ("desktop-file-utils" ,desktop-file-utils)
- ("intltool" ,intltool)))
- (inputs `(("bash" ,bash)
- ("gtk+" ,gtk+)
- ("eudev" ,eudev)
- ("shared-mime-info" ,shared-mime-info)
- ("ffmpegthumbnailer" ,ffmpegthumbnailer)
- ("jmtpfs" ,jmtpfs)
- ("lsof" ,lsof)
- ("udisks" ,udisks)))
+ (build-system glib-or-gtk-build-system)
+ (native-inputs
+ `(("desktop-file-utils" ,desktop-file-utils)
+ ("glib:bin" ,glib "bin")
+ ("gtk+:bin" ,gtk+ "bin")
+ ("intltool" ,intltool)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("bash" ,bash)
+ ("cairo" ,cairo)
+ ("curlftpfs" ,curlftpfs)
+ ("dbus" ,dbus)
+ ("eject" ,eject)
+ ("eudev" ,eudev)
+ ("fakeroot" ,fakeroot)
+ ("ffmpegthumbnailer" ,ffmpegthumbnailer)
+ ("fuseiso" ,fuseiso)
+ ("glib" ,glib)
+ ("gtk+" ,gtk+)
+ ("ifuse" ,ifuse)
+ ("jmtpfs" ,jmtpfs)
+ ("ktsuss" ,ktsuss)
+ ("libx11" ,libx11)
+ ("lsof" ,lsof)
+ ("pango" ,pango)
+ ("shared-mime-info" ,shared-mime-info)
+ ("startup-notification" ,startup-notification)
+ ("sudo" ,sudo)
+ ("udevil" ,udevil)
+ ("wget" ,wget)))
(arguments
- `(#:configure-flags (list (string-append "--with-bash-path="
- (assoc-ref %build-inputs "bash")
- "/bin/bash")
- (string-append "--sysconfdir="
- (assoc-ref %outputs "out")
- "/etc"))))
+ `(#:configure-flags (list
+ (string-append "--with-bash-path="
+ (assoc-ref %build-inputs "bash")
+ "/bin/bash")
+ (string-append "--sysconfdir="
+ (assoc-ref %outputs "out")
+ "/etc"))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch
+ (lambda _
+ (substitute* "etc/spacefm.conf"
+ (("#terminal_su=/bin/su")
+ (string-append "terminal_su="
+ (string-append (assoc-ref %build-inputs "sudo")
+ "/bin/sudo"))))
+ (substitute* "etc/spacefm.conf"
+ (("#graphical_su=/usr/bin/gksu")
+ (string-append "graphical_su="
+ (string-append (assoc-ref %build-inputs "ktsuss")
+ "/bin/ktsuss"))))
+ #t)))))
(home-page "https://ignorantguru.github.io/spacefm/")
(synopsis "Multi-panel tabbed file manager")
(description "SpaceFM is a graphical, multi-panel, tabbed file manager