summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Brielmaier <jonathan.brielmaier@web.de>2020-04-13 19:25:08 +0200
committerGuix Patches Tester <>2020-04-14 19:16:31 +0100
commitf60c1b4ce732db9165732160cf052bc05034d2dd (patch)
tree48a78b37d24b614973fb04ed36507bc847840af9
parent53adc3684ff77b6470c3cf58ad1acb841453729e (diff)
downloadpatches-series-3527.tar
patches-series-3527.tar.gz
gnu: Add chatty.series-3527
* gnu/packages/messaging.scm (chatty): New variable.
-rw-r--r--gnu/packages/messaging.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 98b8fb2637..075d69ed81 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -2146,4 +2146,42 @@ support for high performance Telegram Bot creation.")
(home-page "https://source.puri.sm/Librem5/purple-mm-sms")
(license license:gpl2+)))
+(define-public chatty
+ (package
+ (name "chatty")
+ (version "0.1.9")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://source.puri.sm/Librem5/chatty.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "18cjm24sj3sm9n2888id9dmzqn3fp5yrwvfkxfbjmvhvv1hyckj8"))))
+ (build-system meson-build-system)
+ (native-inputs
+ `(("desktop-file-utils" ,desktop-file-utils) ; for update-desktop-database
+ ("gettext" ,gettext-minimal)
+ ("glib:bin" ,glib "bin")
+ ("gtk+:bin" ,gtk+ "bin")
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("evolution-data-server" ,evolution-data-server) ;libebook-contacts
+ ("feedbackd" ,feedbackd)
+ ("folks" ,folks)
+ ("libgcrypt" ,libgcrypt)
+ ("libgee" ,libgee)
+ ("libhandy" ,libhandy)
+ ("pidgin" ,pidgin)
+ ("purple-mm-sms" ,purple-mm-sms)
+ ("sqlite" ,sqlite)))
+ (propagated-inputs
+ `(("adwaita-icon-theme" ,adwaita-icon-theme)))
+ (synopsis "Mobile client for XMPP and SMS messaging")
+ (description "Chatty is a chat program for XMPP and SMS. It works on mobile
+as well as on desktop platforms. It's based on libpurple and ModemManager.")
+ (home-page "https://source.puri.sm/Librem5/chatty")
+ (license license:gpl3+)))
+
;;; messaging.scm ends here