summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandros Theodotou <alex@zrythm.org>2020-04-10 13:34:17 +0100
committerGuix Patches Tester <>2020-04-10 13:44:12 +0100
commit8abbfcce37866083304682dbca36de7e19c6498f (patch)
tree14fd46adcba4b5e1041e65a63d12c5c24b8a7d8c
parentd90286ed5467bb7a0d50aabf252cf7fda78e97dc (diff)
downloadpatches-series-3489.tar
patches-series-3489.tar.gz
gnu: Add bchoppr.series-3489
* gnu/packages/music.scm (bchoppr): new variable.
-rw-r--r--gnu/packages/music.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 5257d9463a..fb8c0445bb 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -5422,3 +5422,25 @@ plugin and a standalone JACK application.")
offers an LV2 version ported by moddevices.")
(home-page "http://tap-plugins.sourceforge.net/")
(license license:gpl2))))
+
+(define-public bchoppr
+ (package
+ (inherit bsequencer)
+ (name "bchoppr")
+ (version "1.4.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/sjaehn/BChoppr.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1qq1bg1p4qawhwdag0j8hvf6kdsxkyn8gdjd9pbx00p1i314mp6r"))))
+ (synopsis "Audio stream-chopping LV2 plugin")
+ (description "B.Choppr cuts the audio input stream into a repeated
+sequence of up to 16 chops. Each chop can be leveled up or down (gating).
+B.Choppr is the successor of B.Slizr.")
+ (home-page "https://github.com/sjaehn/BChoppr")
+ (license license:gpl3+)))