summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEkaitz Zarraga <ekaitz@elenq.tech>2020-04-07 18:56:06 +0200
committerGuix Patches Tester <>2020-04-07 22:26:13 +0100
commit28f9a5d7a259103b2eb6dfada32571a2b24e7807 (patch)
tree1c3e32f0be91884dbfb5865964cfcadbe90bad3c
parent1c86577d624b97a03138640b4d849823b504570e (diff)
downloadpatches-series-3465.tar
patches-series-3465.tar.gz
gnu: Add meshlabseries-3465
-rw-r--r--gnu/packages/engineering.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 5405db762c..85efc01c4c 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -2491,3 +2491,42 @@ without any changes. And programmers that are familiar with the magellan API
can continue using it with a free library without the restrictions of the
official SDK.")
(license license:bsd-3)))
+
+(define-public meshlab
+ (let ((commit-ref "Meshlab-2020.04"))
+ (package
+ (name "meshlab")
+ (version commit-ref)
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/cnr-isti-vclab/meshlab")
+ (commit commit-ref)
+ (recursive? #t)))
+ (sha256
+ (base32 "1vx9jcsnnxvzi90pcxpp7p72cqg3cm6jiivdmrxkzhr2fiz3pfvr"))))
+ (build-system cmake-build-system)
+ (native-inputs
+ `(("qtbase" ,qtbase)
+ ("qtscript" ,qtscript)
+ ("qtxmlpatterns" ,qtxmlpatterns)
+ ("mesa", mesa)
+ ("glu", glu)))
+ (arguments
+ `(#:tests? #f
+ #:validate-runpath? #f
+ #:phases (modify-phases %standard-phases
+ (add-after 'unpack 'go-to-source-dir
+ (lambda _ (chdir "src") #t)))))
+ (synopsis
+ "The open source system for processing and editing 3D triangular meshes.")
+ (home-page "http://www.meshlab.net/")
+ (description "MeshLab is an open source, portable, and extensible system
+for the processing and editing of unstructured large 3D triangular meshes. It
+is aimed to help the processing of the typical not-so-small unstructured models
+arising in 3D scanning, providing a set of tools for editing, cleaning,
+healing, inspecting, rendering and converting this kind of meshes. These tools
+include MeshLab proper, a versatile program with a graphical user interface,
+and meshlabserver, a program that can perform mesh
+processing tasks in batch mode, without a GUI.")
+ (license license:gpl3+))))