summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandros Theodotou <alex@zrythm.org>2020-04-06 15:10:06 +0100
committerGuix Patches Tester <>2020-04-06 15:19:06 +0100
commit6f9f5679b048c5b882c3272ad92c57f19bb54abf (patch)
tree56c4a34326461c412db1e55971a216cf37453fa2
parent373fde625d21065b195d43e3ef98ea374479852e (diff)
downloadpatches-series-3455.tar
patches-series-3455.tar.gz
gnu: Add shiru-lv2.series-3455
* gnu/packages/music.scm (shiru-lv2): New variable.
-rw-r--r--gnu/packages/music.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index e2a3d84572..85e5fa20cb 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -5387,3 +5387,33 @@ filtered, pitch shifted and ultimately disintegrated. This is an unofficial
port of the Regrader plugin created by Igorski. It is available as an LV2
plugin and a standalone JACK application.")
(license license:expat)))
+
+(define-public shiru-lv2
+ (package/inherit dragonfly-reverb
+ (name "shiru-lv2")
+ (version "0.0.0-20200406")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/linuxmao-org/shiru-plugins.git")
+ (commit "08853f99140012234649e67e5647906fda74f6cc")
+ ;; Bundles a specific commit of the DISTRHO plugin framework.
+ (recursive? #t)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "00rf6im3rhg98h60sgl1r2s37za5vr5h14pybwi07h8zbc8mi6fm"))))
+ (inputs
+ `(("cairo", cairo)
+ ("glu", glu)
+ ("jack", jack-1)
+ ("lv2", lv2)
+ ("mesa", mesa)
+ ("pango", pango)))
+ (synopsis "Audio plugin collection")
+ (description "Shiru plugins is a collection of audio plugins created
+by Shiru, ported to LV2 by the Linux MAO project using the DISTRHO plugin
+framework.")
+ (home-page "http://shiru.untergrund.net/software.shtml")
+ (license license:wtfpl2)))