summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoseph LaFreniere <joseph@lafreniere.xyz>2020-04-04 09:50:56 -0500
committerGuix Patches Tester <>2020-04-04 16:37:05 +0100
commit6a2897a565341656c6efd424f1b91be806a2fd07 (patch)
treedcbba6eca912e9da8339544b390cd1b390456904
parentf2d97d577d1dd527bbc707d857ccd0de81714420 (diff)
downloadpatches-series-3432.tar
patches-series-3432.tar.gz
gnu: Add emacs-flymake-shellcheck.series-3432
* gnu/packages/emacs-xyz.scm (emacs-flymake-shellcheck): New variable.
-rw-r--r--gnu/packages/emacs-xyz.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index cd2562103c..eb62bc578b 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -163,6 +163,7 @@
#:use-module (gnu packages sqlite)
#:use-module (gnu packages gnupg)
#:use-module (gnu packages video)
+ #:use-module (gnu packages haskell-apps)
#:use-module (gnu packages haskell-xyz)
#:use-module (gnu packages wordnet)
#:use-module (gnu packages photo)
@@ -3548,6 +3549,43 @@ It also provides an easy way to find synonyms and antonyms for a given
word (to avoid repetitions for example).")
(license license:gpl3+)))
+(define-public emacs-flymake-shellcheck
+ (let ((version "0.1")
+ (revision "0")
+ (commit "bb413006afc23105a0f84df6fb82504a06483a55"))
+ (package
+ (name "emacs-flymake-shellcheck")
+ (version (git-version version revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/federicotdn/flymake-shellcheck.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "09cqn0255pxim34v5zfypbzr4clfd2ajlsyxpc9h64wg6v9876y5"))))
+ (build-system emacs-build-system)
+ (inputs
+ `(("shellcheck" ,shellcheck)))
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'hardcode-shellcheck-path
+ (lambda _
+ (let ((file "flymake-shellcheck.el"))
+ (chmod file #o644)
+ (emacs-substitute-sexps file
+ ("(defcustom flymake-shellcheck-path"
+ (which "shellcheck")))))))))
+ (home-page "https://github.com/federicotdn/flymake-shellcheck")
+ (synopsis "A bash/sh Flymake backend powered by ShellCheck")
+ (description
+ "This package adds a @code{shellcheck} backend to Flymake. The
+recommended usage is to add @code{flymake-shellcheck-load} to
+@code{sh-mode-hook}.")
+ (license license:gpl3+))))
+
(define-public emacs-flycheck-rust
(package
(name "emacs-flycheck-rust")