summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVagrant Cascadian <vagrant@debian.org>2020-03-14 18:54:50 -0700
committerGuix Patches Tester <>2020-03-30 18:36:07 +0100
commitd78f07bfff4b500d319bf32ae8aba53a72a4a2c7 (patch)
tree674a92c8f1b7312eb7241ddd73eeb62f02ca9402
parent5199be620f2a8f42fd5427ad000f8f215a852426 (diff)
downloadpatches-series-3359.tar
patches-series-3359.tar.gz
gnu: Add linux-libre 5.5.series-3359
* gnu/packages/linux (deblob-scripts-5.5): New variable. (linux-libre-5.5-version): New variable. (linux-libre-5.5-pristine-source): New variable. (linux-libre-5.5-source): New variable. (linux-libre-headers-5.5): New variable. (linux-libre-5.5): New variable.
-rw-r--r--gnu/packages/linux.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 701df764cd..6b406f8dc5 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -192,6 +192,12 @@ defconfig. Return the appropriate make target if applicable, otherwise return
"deblob-check"))
(sha256 deblob-check-hash))))
+(define deblob-scripts-5.5
+ (linux-libre-deblob-scripts
+ "5.5.13"
+ (base32 "1vj3rnrbkhj86lkabhrcm8qiqcz1lqi0lk54ysmg3lanf2vqgvab")
+ (base32 "1r87n60a1ksajqvkra55w4fa2iwsbhys3id8z2j179429pm0ybwn")))
+
(define deblob-scripts-5.4
(linux-libre-deblob-scripts
"5.4.28"
@@ -362,6 +368,14 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
"linux-" version ".tar.xz"))
(sha256 hash)))
+(define-public linux-libre-5.5-version "5.5.13")
+(define-public linux-libre-5.5-pristine-source
+ (let ((version linux-libre-5.5-version)
+ (hash (base32 "1qjf18qywzrfdzwpgpf6m0w0bil8rbc9hby8473ckzvbl0a3cfqz")))
+ (make-linux-libre-source version
+ (%upstream-linux-source version hash)
+ deblob-scripts-5.5)))
+
(define-public linux-libre-5.4-version "5.4.28")
(define-public linux-libre-5.4-pristine-source
(let ((version linux-libre-5.4-version)
@@ -430,6 +444,15 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
(patches (append (origin-patches source)
patches))))
+(define-public linux-libre-5.5-source
+ (source-with-patches linux-libre-5.5-pristine-source
+ (list %boot-logo-patch
+ %linux-libre-arm-export-__sync_icache_dcache-patch
+ ;; Pinebook Pro patch from linux-next,
+ ;; can be dropped for linux-libre 5.7
+ (search-patch
+ "linux-libre-support-for-Pinebook-Pro.patch"))))
+
(define-public linux-libre-5.4-source
(source-with-patches linux-libre-5.4-pristine-source
(list %boot-logo-patch
@@ -529,6 +552,10 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
(description "Headers of the Linux-Libre kernel.")
(license license:gpl2)))
+(define-public linux-libre-headers-5.5
+ (make-linux-libre-headers* linux-libre-5.5-version
+ linux-libre-5.5-source))
+
(define-public linux-libre-headers-5.4
(make-linux-libre-headers* linux-libre-5.4-version
linux-libre-5.4-source))
@@ -793,6 +820,12 @@ It has been modified to remove all non-free binary blobs.")
;;; Generic kernel packages.
;;;
+(define-public linux-libre-5.5
+ (make-linux-libre* linux-libre-5.5-version
+ linux-libre-5.5-source
+ '("x86_64-linux" "i686-linux" "armhf-linux" "aarch64-linux" "riscv64-linux")
+ #:configuration-file kernel-config))
+
(define-public linux-libre-5.4
(make-linux-libre* linux-libre-5.4-version
linux-libre-5.4-source