summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHamzeh Nasajpour <h.nasajpour@pantherx.org>2020-03-28 21:11:06 +0430
committerGuix Patches Tester <>2020-03-30 03:37:04 +0100
commitfa4c5dd81649cf3759b3cc33d44a71d4e83135e4 (patch)
treebeec62fa9c15d28ec896a4d7f372acd4f901a7bb
parent3e3364fc526e1a54ea7744361ffcf6a59a6610a8 (diff)
downloadpatches-series-3327.tar
patches-series-3327.tar.gz
gnu: Add lxqt-organizer.series-3327
* gnu/packages/lxqt.scm (lxqt-organizer): New variable.
-rw-r--r--gnu/packages/lxqt.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/lxqt.scm b/gnu/packages/lxqt.scm
index a440491633..7ef6ca51ce 100644
--- a/gnu/packages/lxqt.scm
+++ b/gnu/packages/lxqt.scm
@@ -1269,6 +1269,40 @@ QTermWidget.")
easily publishing them on internet image hosting services.")
(license license:gpl2+)))
+(define-public lxqt-organizer
+ (package
+ (name "lxqt-organizer")
+ (version "v0.003")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url (string-append "https://github.com/lxqt/organizer.git"))
+ (commit "5aa556aa0f0409e00fac5b63d9118ff228d2e840")
+ (recursive? #t)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1czs9gca7aqsfcnxhi7nzq97pxbmhfgbfh00j7nl8cig0yxb6apv"))))
+ (build-system cmake-build-system)
+ (inputs
+ `(("kwindowsystem" ,kwindowsystem)
+ ("liblxqt" ,liblxqt)
+ ("libqtxdg" ,libqtxdg)
+ ("qtbase" ,qtbase)
+ ("qtsvg" ,qtsvg)
+ ;;("qtlinguist" ,qttools)
+ ("qtx11extras" ,qtx11extras)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("lxqt-build-tools" ,lxqt-build-tools)
+ ("qttools" ,qttools)))
+ (arguments
+ '(#:tests? #f))
+ (home-page "https://lxqt.org/")
+ (synopsis "LXQt Organizer is a lightweight organizer for personal information management.")
+ (description
+ "This package provides a Qt-based application for managing meetings, events and other personal information.")
+ (license license:lgpl2.1+)))
(define-public lxqt-archiver
(package