summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFormbi <formbi@protonmail.com>2020-03-21 14:10:01 +0100
committerGuix Patches Tester <>2020-03-21 14:28:18 +0000
commit95b160f39d65569374a08ca24d82364fdfc3006a (patch)
tree0505601458bc961a69a5cc423b6e88c66c894250
parent93a267b7a40a762a66fa5149336f2c5545cbed30 (diff)
downloadpatches-series-3238.tar
patches-series-3238.tar.gz
fix libgccjitseries-3238
-rw-r--r--gnu/packages/gcc.scm12
1 files changed, 11 insertions, 1 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index 3d1ae25dc9..f7b0cf3333 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -713,7 +713,17 @@ as the 'native-search-paths' field."
(for-each delete-file
(find-files (string-append (assoc-ref outputs "out") "/bin")
".*(c\\+\\+|cpp|g\\+\\+|gcov|gcc|gcc-.*)"))
- #t))))))))
+ #t))))))
+ (native-search-paths
+ (list (search-path-specification
+ (variable "C_INCLUDE_PATH")
+ (files '("include")))
+ (search-path-specification
+ (variable "CPLUS_INCLUDE_PATH")
+ (files '("include")))
+ (search-path-specification
+ (variable "LIBRARY_PATH")
+ (files '("lib" "lib64" "lib/gcc")))))))
(define-public gccgo-4.9