summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdrian Fullmer <adrianfullmer@yahoo.com>2020-03-14 12:42:06 -0500
committerGuix Patches Tester <>2020-03-14 19:37:11 +0000
commitff39f3fa06a44e5d1bbc7cd7aac69527684dfed6 (patch)
tree2ae93cd947611acae02a84b5627bc57fd310f9b0
parentfd5946ce65f21020fa3fa8c79c54f28943859125 (diff)
downloadpatches-series-3166.tar
patches-series-3166.tar.gz
gnu: bitlbee-discord: update to working versionseries-3166
-rw-r--r--gnu/packages/messaging.scm78
1 files changed, 40 insertions, 38 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 72c505c6d9..75cf5375c6 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -223,50 +223,52 @@ identi.ca and status.net).")
(license (list license:gpl2+ license:bsd-2))))
(define-public bitlbee-discord
- (package
- (name "bitlbee-discord")
- (version "0.4.2")
- (source
- (origin
+ (let ((commit "3061edd283b4e886384e5e8cad10f92dc45f3ee7")
+ (revision "0"))
+ (package
+ (name "bitlbee-discord")
+ (version (git-version "0.4.2" revision commit))
+ (source
+ (origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/sm00th/bitlbee-discord.git")
- (commit version)))
+ (commit commit)))
(file-name (git-file-name name version))
(sha256
- (base32 "02pigk2vbz0jdz11f96sygdvp1j762yjn62h124fkcsc070g7a2f"))))
- (build-system gnu-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'patch-autogen
- (lambda _
- (let ((sh (which "sh")))
- (substitute* "autogen.sh" (("/bin/sh") sh))
- (setenv "CONFIG_SHELL" sh))
- #t))
- (replace 'configure
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (invoke "./configure"
- (string-append "--with-bdatadir="
- (assoc-ref outputs "out")
- "/share/bitlbee/")
- (string-append "--with-plugindir="
- (assoc-ref outputs "out")
- "/lib/bitlbee/")))))))
- (inputs `(("glib" ,glib)))
- (native-inputs `(("pkg-config" ,pkg-config)
- ("autoconf" ,autoconf)
- ("automake" ,automake)
- ("texinfo" ,texinfo)
- ("libtool" ,libtool)
- ("bitlbee" ,bitlbee) ; needs bitlbee headers
- ("bash" ,bash)))
- (synopsis "Discord plugin for Bitlbee")
- (description "Bitlbee-discord is a plugin for Bitlbee witch provides
+ (base32 "1d6nkr7wfrhra09ql258hvhr6q8kmnigcr14hjbwk10kqcb277y6"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-autogen
+ (lambda _
+ (let ((sh (which "sh")))
+ (substitute* "autogen.sh" (("/bin/sh") sh))
+ (setenv "CONFIG_SHELL" sh))
+ #t))
+ (replace 'configure
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (invoke "./configure"
+ (string-append "--with-bdatadir="
+ (assoc-ref outputs "out")
+ "/share/bitlbee/")
+ (string-append "--with-plugindir="
+ (assoc-ref outputs "out")
+ "/lib/bitlbee/")))))))
+ (inputs `(("glib" ,glib)))
+ (native-inputs `(("pkg-config" ,pkg-config)
+ ("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("texinfo" ,texinfo)
+ ("libtool" ,libtool)
+ ("bitlbee" ,bitlbee) ; needs bitlbee headers
+ ("bash" ,bash)))
+ (synopsis "Discord plugin for Bitlbee")
+ (description "Bitlbee-discord is a plugin for Bitlbee witch provides
access to servers running the Discord protocol.")
- (home-page "https://github.com/sm00th/bitlbee-discord/")
- (license license:gpl2+)))
+ (home-page "https://github.com/sm00th/bitlbee-discord/")
+ (license license:gpl2+))))
(define-public hexchat
(package