summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRafael Luque Leiva <rafael.luque@osoco.es>2020-02-05 17:07:23 +0100
committerGuix Patches Tester <>2020-02-05 18:32:09 +0000
commit8e461f2ebd1b8f5cb2325aa539ef82a8ba30d84a (patch)
tree97017ee8772ab94fa2e56cf4d15424f8885e8b13
parent668307c0d4f35743fb9fcad7f2198aa9b31ba6d5 (diff)
downloadpatches-series-2814.tar
patches-series-2814.tar.gz
Add rticles R packageseries-2814
-rw-r--r--gnu/packages/cran.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 58ceed06d0..c31d9dd8a6 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -18,6 +18,7 @@
;;; Copyright © 2018, 2019 Brett Gilio <brettg@gnu.org>
;;; Copyright © 2019 Nicolò Balzarotti <anothersms@gmail.com>
;;; Copyright © 2019 Wiktor Żelazny <wzelazny@vurv.cz>
+;;; Copyright © 2020 Rafael Luque Leiva <rafael.luque@osoco.es>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -79,6 +80,32 @@
#:use-module (gnu packages web)
#:use-module (gnu packages xorg))
+(define-public r-rticles
+ (package
+ (name "r-rticles")
+ (version "0.14")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "rticles" version))
+ (sha256
+ (base32
+ "1377fib4asazhhki4aajvld0wa35vd3zjvyl3lf2hjm2qk3vyak7"))))
+ (properties `((upstream-name . "rticles")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-knitr" ,r-knitr)
+ ("r-rmarkdown" ,r-rmarkdown)
+ ("r-tinytex" ,r-tinytex)
+ ("r-xfun" ,r-xfun)
+ ("r-yaml" ,r-yaml)))
+ (home-page "https://github.com/rstudio/rticles")
+ (synopsis "Article Formats for R Markdown")
+ (description
+ "This package provides a suite of custom R Markdown formats and templates
+for authoring journal articles and conference submissions.")
+ (license license:gpl3)))
+
(define-public r-clipr
(package
(name "r-clipr")