summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Brielmaier <jonathan.brielmaier@web.de>2020-01-27 19:10:10 +0100
committerGuix Patches Tester <>2020-01-27 18:27:10 +0000
commit34c6fbdf20af3aaea690220e92bc39ff34876966 (patch)
treef861af4dedb2b2a315b0f662e50cf4b6fa39aa59
parentfcb510c541e83291ea6682cba87020a913c64914 (diff)
downloadpatches-series-2733.tar
patches-series-2733.tar.gz
gnu: Add chatty.series-2733
* gnu/packages/messaging.scm (chatty): New variable.
-rw-r--r--gnu/packages/messaging.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 81569d29b9..ae368fedf9 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -18,6 +18,7 @@
;;; Copyright © 2019 Tanguy Le Carrour <tanguy@bioneland.org>
;;; Copyright © 2019, 2020 Brett Gilio <brettg@gnu.org>
;;; Copyright © 2019, 2020 Timotej Lazar <timotej.lazar@araneo.si>
+;;; Copyright © 2020 Jonathan Brielmaier <jonathan.brielmaier@web.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -55,6 +56,7 @@
#:use-module (gnu packages documentation)
#:use-module (gnu packages enchant)
#:use-module (gnu packages fontutils)
+ #:use-module (gnu packages freedesktop)
#:use-module (gnu packages gettext)
#:use-module (gnu packages glib)
#:use-module (gnu packages gnome)
@@ -1995,4 +1997,40 @@ support for high performance Telegram Bot creation.")
(home-page "https://core.telegram.org/tdlib")
(license license:boost1.0))))
+(define-public chatty
+ (package
+ (name "chatty")
+ (version "0.1.7")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://source.puri.sm/Librem5/chatty.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1prqd2dnib3j12pjiplzr2rim9q617vmvzv76lgmz0n3bmp7v7ma"))))
+ (build-system meson-build-system)
+ (native-inputs
+ `(("desktop-file-utils" ,desktop-file-utils) ;for update-desktop-database
+ ("evolution-data-server" ,evolution-data-server) ;libebook-contacts
+ ("folks" ,folks)
+ ("gettext" ,gettext-minimal)
+ ("glib:bin" ,glib "bin")
+ ("gtk+:bin" ,gtk+ "bin")
+ ("libgcrypt" ,libgcrypt)
+ ("libgee" ,libgee)
+ ("libhandy" ,libhandy)
+ ("pidgin" ,pidgin)
+ ("purple-mm-sms" ,purple-mm-sms)
+ ("pkg-config" ,pkg-config)
+ ("sqlite" ,sqlite)))
+ (propagated-inputs
+ `(("hicolor-icon-theme" ,hicolor-icon-theme)))
+ (synopsis "Mobile client for XMPP and SMS messaging")
+ (description "Chatty is a chat program for XMPP and SMS. It works on mobile
+as well as on desktop platforms. It's based on libpurple and ModemManager.")
+ (home-page "https://source.puri.sm/Librem5/chatty")
+ (license license:gpl3+)))
+
;;; messaging.scm ends here