summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillaume Salvan via Guix-patches via <guix-patches@gnu.org>2020-01-10 13:35:25 +0000
committerGuix Patches Tester <>2020-01-12 09:45:54 +0000
commit2a614f7a6475fcfe009ff70f87e2a1513f5d1679 (patch)
tree717cfc7b6cda540237aa84974011a3928f87eba9
parentd75a0cd98649c610c8c6ed05011233a49af156e9 (diff)
downloadpatches-series-2605.tar
patches-series-2605.tar.gz
Add ghc-clayseries-2605
-rw-r--r--gnu/packages/haskell-web.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/haskell-web.scm b/gnu/packages/haskell-web.scm
index 5888e8542e..793068e46a 100644
--- a/gnu/packages/haskell-web.scm
+++ b/gnu/packages/haskell-web.scm
@@ -1595,3 +1595,27 @@ cookies, serving files, and more.")
(description
"Haskell library which exposes zero-copy sendfile functionality in a portable way.")
(license license:bsd-3)))
+
+(define-public ghc-clay
+ (package
+ (name "ghc-clay")
+ (version "0.13.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://hackage.haskell.org/package/clay/clay-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "192lsbyj6azjs2ygpx4i47fyr8zfmvwcas8mia07ndqglk2c9csx"))))
+ (build-system haskell-build-system)
+ (arguments `(#:tests? #f)) ;; Fix tests
+ (home-page "http://fvisser.nl/clay/")
+ (synopsis
+ "CSS preprocessor as embedded Haskell")
+ (description
+ "Clay is a CSS preprocessor like LESS and Sass,
+but implemented as an embedded domain specific language.")
+ (license license:bsd-3)))